Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I own a dedicated server with a domain, we'll say foobar.com. I use google apps to manage my email SMTP servers.

Now I don't check two gmail inboxes. I have my own personal one, and then I have foobar.com's inbox from google apps. Naturally the easiest thing to do is just have all foobar's emails forwarded to my personal one. So then I am only checking 1 inbox. This is all fine and dandy.

I use MSMTP that with a wrapper that uses /etc/aliases. I have it set so any mail attempting to go to root (Things from cron, etc) will go to support@foobar.com.

So when google app's (foobar.com) gets an email from the email I have setup with it (support@foobar.com), it automatically doesn't forward the message. This is a "feature" to gmail/google apps I suppose.

How do I get around it? workarounds? etc. I could just have my alias set to my personal email but I wanted a place to have all foobar related emails archived in one place (googleapps).

share|improve this question

migrated from superuser.com Dec 31 '10 at 3:16

This question came from our site for computer enthusiasts and power users.

3 Answers 3

Create the user "support" in your Google Apps admin page, and then log into that user directly. From the user's settings page, you should be able to set forwarding options as normal, and have that forward to your main email address, and set up a filter based on the To: field (e.g. if To:support@foobar.com - apply label "Support")

share|improve this answer
    
I know. I do that currently. Gmail refuses to forward emails that are sent to itself. I set all emails to support@foobar.com to forward to my personal email. If I email from: support@foobar.com to: support@foobar.com ...it never forwards –  ParoX Dec 31 '10 at 4:21
    
Not sure I fully understand, but can you setup an alias on your own account like bhare+foobar@personal.com, forward the support@foobar.com to that, and then filter on your personal side? –  user7543 Dec 31 '10 at 4:39

I had this problem before and took me days to figure out.

It is related to your server setting, not Google Apps. I assume your server is running cPanel.

  1. log in cPanel account of the account (domain)
  2. Click "MX Entry" under "Mail"
  3. Select your domain from the drop down list
  4. Select "Remote Mail Exchanger" under "Email Routing"
  5. Click "Change" button and you are done.

If you do not set email routing to "remote mail exchanger", the email will be delivered locally when sent from the server, thus you don't get the emails in Google Apps (external mail server).

Hope this helps.

share|improve this answer
    
Nope I do not have cPanel –  ParoX Feb 21 '11 at 20:30
    
I use cPanel as example. Try to check your email routing setting on your server? –  LiewCF Feb 22 '11 at 5:50
up vote 0 down vote accepted

On Feburary 16th, 2011

Emails to root seem to start forwarding to my personal email. I did not change anything on my part so I feel it was either a bug on google's system or apart of the new changes they are doing to Google Apps. This problem is no more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.