Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Since a few months IMDB appears to be "detecting" that I'm coming from a a German IP address and automatically changes the UI to German. More specifically it shows the Germany movie title when it has one.

This is massively annoying and I can't seem to find an obvious toggle to change this.

I do not have an account on IMDB.

Is there a way to prevent this from happening aside from an IMDB account (if that even helps)?

share|improve this question
    
+1 This is indeed annoying. But it's easy to create an account. –  leonbloy Jan 10 '11 at 20:28

4 Answers 4

up vote 2 down vote accepted

As @MathiasKegelmann mentioned, from IMDB's help you have two options:

Don't forget that if you are accessing IMDB through the search engines, then in the second case you will have to change the URL manual all the time, but not in the first one.

share|improve this answer
    
Thanks, this seems to match what IMDB writes on the page that Mathias links to. I will probably accept his answer, allthough really what we need is a merge of the two answers and the addition that the akas.imdb.com page provides a way to force original titles. I know stackexchange site prefer it if the actual answer is in the answer itself and it is not just a link somewhere... suggestions? –  Boris Terzic Jan 10 '11 at 19:56
1  
Great work, that seals the deal I think. –  Boris Terzic Jan 11 '11 at 8:58

I guess http://www.imdb.com/help/show_leaf?titlelanguagedisplay might be what you are looking for.

We recently modified the way titles are displayed on the site. Users will now by default see titles listed in the language used for release in their country (i.e. US-based users will see films listed under the title used for the North American release, while users browsing the site from France will see titles as they appeared on the French release of those movies etc.)

If you are registered on IMDb.com and you prefer to see original titles, or the title in any other language/country of release by default, you can set your user preferences accordingly.

To do this, please click on the 'Your Account' link (located in the upper right corner of every page on IMDb.com) and then click on the 'Site Preferences' option, or go directly to https://secure.imdb.com/register-imdb/siteprefs , and then choose the desired options from the "Title Display Country" and "Title Display Language" dropdown menus. Click 'OK' to save your choice.

For more help/information, please refer to our site preferences help page.

Please also remember that if you access the site through the following URL, you will always see films listed under their original titles regardless of your login status or site preferences:

http://akas.imdb.com

share|improve this answer

Recently, the http://akas.imdb.com endpoint stopped working for me. By default, it will now use your geolocation to provide localized content. However, you can override this behaviour by sending an Accept-Language HTTP header.

Using Ruby, this is how I solved this problem:

require 'open-uri'

IMDB_TOP_URL = 'http://www.imdb.com/chart/top'
HEADERS_HASH = {'Accept-Language' => 'en'}
open(IMDB_TOP_URL, HEADERS_HASH)
share|improve this answer
    
This should now be the accepted answer. Unless you send the Accept-Language: en header akas.imdb.com now returns the page in your local language. –  Dean Jan 19 at 19:38

Thank you @Ashitaka !

Your answer is the correct one,

by the way if any one want's to use jsoup (HTML parser) in java, it's like this :

Document doc = Jsoup.connect("http://www.imdb.com/chart/top").header("Accept-Language", "en").get(); Elements elems = doc.select("td.titleColumn"); for(Element e : elems) { // Do Something }

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.