Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Just noticed that 'Mark unread' link in the footer of each item in Google Reader disappeared.

Tried in different browsers, tried clearing the cache - didn't help. Pressing "M" button does nothing.

How do I get it back?

Here's the screenshot: alt text

Thanks!

share|improve this question
    
Cannot verify -- "Keep Unread" is available to me –  Derek Oct 13 '09 at 23:49
    
When this was first posted I checked and my "keep unread" was gone. However, I just looked again and it is back :-) –  Chris_K Oct 14 '09 at 3:22
    
This happens, it seems, randomly! –  drozzy Jun 16 '10 at 13:04
    
Merge possible: webapps.stackexchange.com/questions/7378/… –  random Jan 13 '11 at 3:52
add comment

migrated from superuser.com Jan 13 '11 at 3:53

This question came from our site for computer enthusiasts and power users.

6 Answers

I think this happens when you "mark all items as read". I hope you'll understand when I DON'T test this myself; I keep items unread all the time.

EDIT: It appears to also happen for really old content. I haven been able to keep up with some of my feeds, and Google Reader eventually decided to mark old items as read and prevented be from undoing it.

share|improve this answer
    
This appears to be true. I've just tested it on one feed and after doing "Mark all as read" then showing all items, they do not have the "Mark as read" checkbox and the M key does not work. –  Randy Orrison Oct 15 '09 at 11:27
    
You are right here, that's exactly it. Thanks! –  Art Dec 8 '09 at 4:30
add comment

This happens for two reasons:

  1. When you click "Mark all as read" button, all feeds mark read at that point cannot be marked unread anymore.
  2. For any items older than precisely one month. Today is June 16th, and I cannot mark "unread" any of the items on or before May16h.

I am not sure what the reason behind this is, but I think it might have something to do with Google storing/caching all the feeds and so they don't want to store more than 1-month worth of them? This is strange, considering that one can still scroll all the way back in history, or query Google Reader for old-feeds (for example using Google Reader api).

share|improve this answer
add comment

I am seeing "Keep Unread" in the footer of Google Reader here, in all browsers.

Google Reader

Try pressing M when you're on an article and see if anything happens (that should toggle the "keep unread" feature).

Can you provide a screenshot?

share|improve this answer
    
m toggles mark read/mark unread –  Anthony Cramp Oct 14 '09 at 1:09
add comment

For the record, it's possible to undo the "mark all as read" action – somewhat unintuitively – by marking only items older than a day/week/two weeks as read:

http://www.technixupdate.com/undo-mark-all-as-read-in-google-reader/

This restores the "keep unread" option!

share|improve this answer
    
this solves it. –  hIpPy Jul 3 '11 at 7:26
add comment

In Google Reader,after subscribe a site,the keep unread is disappear. But if click “all items”,you can see "keep unread" again. maybe this is google reader's bug.

share|improve this answer
add comment

Try to use a mobile device and access Google Reader trough m.google.com/reader . Mark the desired items as stared to access them much easy and there you will have the keep unread feature. Also you can try to revert to the old user interface somehow (for example by disabling javascript in the browser).

share|improve this answer
    
Not what the OP asked. –  Vidar S. Ramdal Nov 6 '12 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.