Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm posting some YouTube videos on my WordPress blog, but they always default to 360p, even though I've provided the &hd=1 parameter. The videos can go up to 1080p if the user selects it, and I'd like to set a default of at least 720p. I don't care if they bump it down or not.

Can this be done?

share|improve this question

migrated from superuser.com Jan 14 '11 at 2:59

This question came from our site for computer enthusiasts and power users.

    
The hd=1 parameter like so? –  digitxp Jan 13 '11 at 22:29
    
Well, to embed it in WordPress I found I had to just link directly to the video. Adding the HTML for the embed didn't work for me. –  Mike Pateras Jan 13 '11 at 22:50
    
This is answered here: stackoverflow.com/questions/7582336/… –  Victor Lyuboslavsky Nov 11 '13 at 14:18
add comment

3 Answers 3

Add this argument to your query string: &vq=hd720

For example:

http://www.youtube.com/embed/n6fUZ5eFaPc?autoplay=1&vq=hd1440
share|improve this answer
add comment

You need to add hd=1&, not just the hd=1. Without the ampersand, it won't work.

Follow our post here.

share|improve this answer
    
Only if the parameter is not the last, i.e. it's followed by other parameters. –  Joachim Pileborg Sep 25 '13 at 3:33
add comment

I'm not sure if you can set the resolution for the user. YouTube's horrible embedded player is AFAIK the same as the horrible player on their webpage, which means the resolution is configured by the user and not the poster.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.