Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Sorry if this is a dumb question, but I really can't seem to figure it out, and of course Facebook help is of... no help at all (as usual).

I manage a bunch of Facebook pages, but never had the necessity to add notes to them; now I have it. So I went to the page settings and enabled the "Notes" applications; and "Notes" actually showed up in the page's menu. But when I click on it, nothing happens: I just go back to my page's wall.

Is this some kind of strange bug or am I missing something?!?

share|improve this question
    
Are you using facebook as you or as another entity, like a community page? I find that a lot of functionality doesn't work when you switch from being you. –  David Mar 11 '11 at 14:48
    
I'm using it as myself, and I am (of course) the admin of the page; I also tried using it as the page itself, but it doesn't work, either. –  Massimo Mar 11 '11 at 14:51

3 Answers 3

up vote 4 down vote accepted

Try https://www.facebook.com/notes.php?id=[YOUR_PAGE_ID]

Or type Notes at the top then search on the left for your Page.

Or go to your Page and click "Use Facebook as [PAGE NAME]" then click Notes

If none of these work then I would contact support.

share|improve this answer
    
The first one worked, I was able to create a note and now I can succesfully access the "Notes" section via the standard link. Looks like it was some sort of bug... –  Massimo Mar 11 '11 at 18:43

Go into 'Admin' (settings), and the 'Apps' menu (down left side), then you can select the 'Notes' app to change it's settings etc.

share|improve this answer

One thing to note is that you can add the Notes application to the favorites.

  1. Switch to "Use Facebook as [my page name]"
  2. Search for the Notes application --> it appears on the left menu
  3. Move the mouse over it, click on the pen appears to its left, and select "Add to Favorites"
share|improve this answer
    
This must have been chosen as the best answer. –  hkBattousai Aug 1 '12 at 13:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.