Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I've recently come across an issue where some Japanese text on certain web pages won't render properly no matter what I do. I've tested many browsers, changed character encoding and even gone as far as changing the OS language and nothing fixes it. All the browser plugins are up-to-date and I've tried safe-mode in Firefox as well.

I've tried Firefox 3, Firefox 4 RC, IE 8, IE 9, Safari 5.0.4 on Windows 7, Mac OS X Snow Leopard, and Ubuntu Maverick Meerkat.

Interestingly enough though the page renders just fine in iOS 4.3's Safari.app on my 4G touch.

I note the fact that if it works on iOS it's definitely not Flash since iOS doesn't support Flash and I've disabled JavaScript in the Safari settings and it still works which leaves me thinking it has something to do with the HTML? Perhaps web standards?

An example link of this problem is here: http://utaten.com/lyric/jb71008071

share|improve this question
    
Can you post an unshortened link please. It's not as if you are having to ask you question in 140 characters or less. Obscuring the link makes people suspicious. –  ChrisF Mar 15 '11 at 22:08
    
Unshortened. Its become a habit for me so I apologize in advance. –  Thardus Mar 17 '11 at 4:25
add comment

1 Answer

It's most likely the font, most fonts simply don't have Japanese characters. If it renders in iOS, that's probably selecting a different font from the CSS than the others. If that's the case, just ensure all the fonts in the CSS list support Japanese.

share|improve this answer
    
How do I change the CSS font/check if the CSS list supports Japanese? –  Thardus Mar 17 '11 at 4:27
    
It is Flash, right click on it. iOS is obviously replacing the Flash with HTML. Embedding fonts into ActionScript is somewhat off-topic for this forum, I'm afraid. –  David Mar 17 '11 at 13:59
    
I can't find anything in the Global Settings Manager that relates to fonts. Interestingly enough right-clicking "Settings..." doesn't do anything but right-clicking "Global Settings..." does. –  Thardus Mar 17 '11 at 20:39
    
If it helps here's a screen cap of what I see when it tries to render the page in Firefox 4: img.ly/images/775860/full –  Thardus Mar 22 '11 at 5:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.