Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

How to turn off scripts in Google Search, in particular the page preview?

share|improve this question

migrated from superuser.com Mar 16 '11 at 15:08

This question came from our site for computer enthusiasts and power users.

1  
and your browser is!? –  MJH Mar 16 '11 at 14:27
    
@MJH, Mozilla Firefox 3.6 with loads of extensions –  Vi0 Mar 16 '11 at 15:27

3 Answers 3

up vote 2 down vote accepted

If you don't mind killing off all other Javascript features, the most reliable way is to just disallow all Javascript for the search page.

No thanks to Google using one domain for so many of its services, you can't do that with NoScript's base functionality, but you can with NoScript's ABE (Application Boundaries Enforcer) subsystem.

Here's a little ABE rule I wrote to kill Google Instant which also does what you want:

Site ^https://encrypted.google.com/(s|search)(\?.*|$)
Deny INC(SCRIPT,XHR)
Sandbox

Further details on this SuperUser answer I wrote earlier:

http://superuser.com/questions/260475/how-to-make-google-search-scriptless-with-noscript-adblock/325939#325939

share|improve this answer

In Firefox Use Greasemonkey and this script http://userscripts.org/scripts/show/90222

share|improve this answer
    
Previews become screwed, but don't disappear and are still loaded when this script is enabled. –  Vi0 Mar 16 '11 at 17:50

For Firefox, you can use this snippet I came up with in your userContent.css file:

@-moz-document regexp("^https{0,1}://([a-zA-Z0-9\\-]+\\.){0,1}google\\..*") {
    .vspii, #nycp { display: none !important; }
    td#leftnav { display: none !important; }
}
share|improve this answer
    
This will only hide it, not prent downloading/slowing things down, won't it? –  Vi0 Dec 31 '11 at 13:56
    
Probably, depending on their exact implementation, which I don't care about at all because seeing it was what irritated me about it. –  zak Jan 1 '12 at 23:22
    
I mostly irritated by slowing down the browser even more and unnecessary traffic. Turned off scripts using NoScript's ABE and now it's OK. –  Vi0 Jan 3 '12 at 7:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.