Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Attachments in Gmail are marked in threaded view with a paperclip icon next to each message that has an attachment

paperclip shown

and also in the search results as with the first message below:

single paperclip

However, sometimes it is not shown, as with the second message above and in the threaded view of that same conversation below:

paperclip missing

How do you make them all show? It is very tedious to find attachments you know are there when the icon shows up in neither the search results nor the threaded view.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

There's no easy way to fix this.

Here's what I did:

  1. Go to Settings...Filters.
  2. Click on Create a New Filter.
  3. Select Has Attachment.
  4. Click on Next Step.
  5. Click on Apply the label, and select New Label from the dropdown.
  6. Type in the new label in the dialog box that pops up.
  7. Click Create Filter, and apply it to all conversations in the inbox.

Here's the downside: Any email with images in it will trigger this, because by definition they are attachments.

The good news is it will also get messages where the attachment was further down and not in the most recent thread of the conversation.

share|improve this answer

If you're using chrome there is a great extension that fixes this problem as well as displaying the icons of the filetypes, as well as a lot of other things. It's called: Better Gmail

On a side note you can also put in your search: has:attachment to only include results that have an attachment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.