Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I logged into Google Groups and, to my horror, that the interface language changed to Hebrew, probably because I'm accessing the site from Israel. (I speak Hebrew, but rather not use it on the computer.)

How do I change the language? I couldn't find any link for changing it to English.

share|improve this question
up vote 4 down vote accepted

Try gl=us or hl=en in the URL to force a change to the site.

share|improve this answer
1  
Awesome, hl=en worked. – Ram Rachum Apr 18 '11 at 21:05

It should respect your language preference set at http://www.google.com/preferences. Does that make it permanent for you?

share|improve this answer
    
even if I set my preferences at the link you cited, the default language still reverts to my locale :( – Kit Jun 10 '11 at 2:03

Go to Google home page in English and then on the right end of the screen next to sign-in option there is small block of tiny squares (Google Apps) click on that, a drop down menu appears, at the bottom click "more" and the menu scrolls up with another hyperlink Even more from Google at the bottom. Click on that link and Google products page opens up, now scroll down to the bottom. You will find "Groups" under the social tab. Click on this link and it opens up in English and then you may choose to sign-in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.