Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The "Go to Label" Lab feature should work as follows:

  • Press g then l (goto label)
  • Hovering input box opens
  • Start typing a label's name or a folder name (Inbox, Trash, etc.)
    • Suggestions appear as I type to a dropdown list
  • Select a label from the list / type the whole label
  • Submit
  • Page in:<name> (or label:<name>) opens

HOWEVER When I trigger the keyboard shortcut, hovering input box opens with l already put*. Suggestions won't appear. Nothing happens when I press enter.

2011-06-30 Pressing g then l won't even show the input box anymore.

The feature is broken. I have tried Chrome, Firefox, Safari and Opera on OS X.

I have the following other Labs features enabled**:

  • Extra Emoji
  • Search from autocompletion
  • Undo send
  • Add images
  • Unread messages icon
  • Send & Archive
  • Mark as read button
  • Title improvements
  • Fetch POP-accounts
  • Recently used Emoji
  • Signature tweaks
  • Go to label (duh)
  • Message peek

Are any/some/a combination of these known to be in conflict with the "Go to label"? With my current Labs settings there is quite a lot of possible combinations, so trial & error might not be worth the hassle as I still can use the search box and click on the labels on the list on the left.

Also @Al Everett confirmed the Go to Label works for him as advertised, so I believe some other Lab feature is preventing it from working correctly. (I might investigate this, unless someone knows the answer straight away.)

For what it's worth, I actually have Google Apps mail — but a help article suggests the versions don't differ that much.

*) The l isn't input in Firefox, otherwise it (dys)functions the same
**) These are translations from their Finnish namesakes so it may not be 1:1 correct.

share|improve this question
I can't reproduce this; it works as advertised for me. Is this still happening to you? – Al E. Jun 27 '11 at 17:46
@Al now that you mention it, pressing g then l will not do anything anymore for me; won't even show the input box (tested Chrome, Firefox, Opera and Safari on OSX). Could you tell me what other Lab features you are using? – koiyu Jun 30 '11 at 10:02
A lot of them. I'm not using mouse gestures or custom keyboard shortcuts, which I think would be most likely to interfere. I'm also not using Google Apps, which may be the key difference. – Al E. Jun 30 '11 at 12:12

I had the same problem, but the solution for me was to disable the "Preview Pane" Gmail lab.

share|improve this answer
Disabling the "Preview Pane" fixed this for me. Thanks Ben. – Luke Aug 18 '11 at 23:45
up vote 2 down vote accepted

It seems the problem is in the language versions:

  • Tried vanilla GMail account (w/ keyboard shortcuts turned on) with all the same Labs enabled → not working
  • Disabled all other Labs but "go to label" → not working
  • Switched language to "English (US)" → works

I tested some other languages as well. Both English US & UK seem to be the only ones that have working Go to label feature. (I was going through the language list alphabetically and when all Spanish, German and French failed, I stopped.)

Changing the language to English in my primary Google Apps Mail account "solved" the problem there too.

UPDATE Using the Gmail's new look also seems to fix the issue. (Well at least for Finnish, so probably for other languages as well.)

share|improve this answer
Thanks Koiyu, you hit the point! this is a language issue. I changed into english and now "g+l" works again. It's kinda weird because I have always used the same language in gmail (catalan) and "g+l" worked as well. Thanks! – user12026 Jul 8 '11 at 6:45

protected by Community Nov 19 '11 at 13:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.