Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm using Google Docs to edit a large document that I need to access from my 2 laptops and 1 desktop. All is good except when at office, the Google Docs always freezes with message "trying to reach google" when it tries to auto-save my edit.

I suspect it is probably due to my office network restriction on HTTPS connections, but I cannot do anything about that restriction. Rather, I think the auto-save is at fault because it always tries to save my edit even though I just type 1-3 letters in the last 10 seconds and disables the editor while it's doing the saving, and I always end up with frozen editor with "trying to reach google" at the top of the page.

So, how can I disable the Google Docs auto-save feature? (or I'd rather call it a bug for all the troubles it has caused me and many others)

share|improve this question
add comment

5 Answers

Possible solution...?

I found autosave to be the most frustrating "feature" I've ever experienced - especially when editing text in a cell... at one point I timed the autosave refresh and it was kicking in every 11 seconds. This meant that I could edit text for no longer than 11 seconds before it kicked in and wiped out whatever I had typed.

I about gave up and then decided to clear cache and restart the Chrome... presto! After re-entering the Google Sheet and editing text in a cell the autosave feature patiently waited until I was done to save / refresh. Not sure why this worked but give it a try and maybe it will improve the user experience for you as well.

Good luck!

share|improve this answer
add comment

You can't disable auto saving, but you can have it happen offline.

Make sure that you have offline Google Docs enabled and that your document is downloaded.

Then, disconnect the internet. Start editing that document. Now, you will be editing the offline version.

At this point, you can safely reconnect to the internet. This will NOT force you to edit the online version of the document; you will still be editing the offline version until you click on the "reconnect to online docs" link (or whatever it's called).

Thus, you can edit offline even when online. At the end of the day, when you are finished editing, you can reconnect and sync the chances with the online version.

This achieves offline editing without any of the mess of downloading, uploading, and having to deal with conversion and bad formatting.

share|improve this answer
add comment

Yeah, you can't disable it for now but if you really want on-demand saving then you might want to try a compromise. If you have Microsoft Office, you could install Google's Cloud Connect. It is a free plugin that integrates Microsoft Office and Google Docs. With it, you can edit your document offline and then sync your edits with Google Docs.

If you're using OpenOffice then you could use OpenOffice.org2GoogleDocs. It does pretty much the same thing with the added benefit that you could connect it to Zoho Docs and your own WEBDAV servers as well.

share|improve this answer
add comment

I agree with the previous answer in that you can not disable the auto-save but there are a couple easy workarounds that will allow you to work on your document while at the office.

After you login to Google Docs and are looking at your list of documents, hover your mouse over the document in question. You should see an 'Actions' dropdown appear to the right. If you click on that you should be given the option to 'download' the file.

Now you can work on your document locally on your office computer and when you are done for the day just upload it back to Google Docs. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.