Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm using Mail (the Mac OS X app, v4.5) to access my Google Mail account, but every mail sent to my Gmail address arrives twice in Mail.

  1. In the global inbox for the Gmail account
  2. And one in the IMAP folder for the Gmail account in the "All messages" folder
    (In my German version it's the "Alle Nachrichten" folder)

I thought it was because I used filters and labels in Gmail to pre-organize my Mail, but I disabled both filters and labels and the issue still persists.

I want to avoid deleting the "All messages" folder in Mail since I'm afraid I won't be able to access all my mails in my Gmail account from Mail anymore.

Is this a known issue? I know people who use Gmail with Mail who don't have this problem, but I couldn't find out what they had set differently.

EDIT: It appears matthiasr is right. Apple Mail simply can't handle Gmail. I tried "Sparrow", another e-Mail client for Mac which can, however, handle GMail quite nicely. Works like a charm.

Unless anyone can provide a workaround of some sort for Apple Mail, I would mark matthiasr's answer as accepted.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

This is the expected behaviour of GMail via IMAP, and is documented here.

The underlying problem is that the GMail paradigm of having one gigantic pile of mail (All Mail) with tags (and INBOX is just another tag, just one that every new message has attached) does not map well to the folder paradigm underlying IMAP.

Inside GMail, it's completely normal to have a mail show up in Inbox, All Mail and a bunch of other tags as well. IMAP clients (including Apple Mail) don't really expect this and do not realize that these are the same message.

Not much you can do about it, other than hiding the [GMail] hierarchy of folders.

share|improve this answer
    
Thanks for the explanation, but the annoying thing is that Apple Mail shows me I got unread mail, so I still need to mark the dupe as read and when I get 2 or more mails within a few minutes, it becomes annoyingly hard to distinguish dupes from "real" mail. That... is unpleasant. –  Jemus42 May 30 '11 at 16:04
    
Also, every message appears twice in search results. Very annoying. –  Peter Niederwieser Jul 9 '11 at 5:55
add comment

There is a somewhat simple solution to this in the Gmail IMAP settings explained here. This worked for me, although in the current version of mail I did not find the setting to check under the viewing tab in Mail's preferences mentioned at the end. Hope this helps!

share|improve this answer
2  
Give us a summary of the link at least –  Eight Days of Malaise Dec 13 '11 at 5:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.