Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Since upgrading my kids' browser to Firefox 4, YouTube seems to have switched them over to HTML5 video, which the computer apparently can't handle because it stutters horribly, causing Child Rage Syndrome. ;-) IE9 does not pose this problem, it uses the Flash player.

I right-clicked one of the offending videos & navigated to http://www.youtube.com/html5. It initially told us we were in the HTML5 trial, and so I clicked to opt out. I then exited the browsers & ran ccleaner to ditch the cached stuff.

No fix. Now the above YouTube page tells us we are not in the HTML5 trial, but we are still getting the laggy, HTML5 video (I can tell based on the right-click menu that comes up). My kids have switched to Internet Explorer, but they miss Firefox (and in particular adblockplus).

Is there a way to get YouTube to really switch us over to flash?

share|improve this question
    
What is the offending video ? Videos with ads play via the Flash Player. –  phwd May 30 '11 at 20:00
    
What happens if you toggle off HTML wuing this extension: addictivetips.com/internet-tips/… –  Ciaran May 31 '11 at 5:12
    
This is not a true solution but more of a workaround. You could add one of the browser agent switchers to Firefox and make it look like FF4 for Google: addons.mozilla.org/en-US/firefox/addon/user-agent-switcher –  JCL1178 Aug 10 '11 at 2:30
add comment

migrated from superuser.com May 30 '11 at 18:26

This question came from our site for computer enthusiasts and power users.

3 Answers

I'm not sure about Flash, but I recognize the problem you're having. Firefox's <video> support hasn't yet been done properly, so it's much slower than any other method.

If nobody else suggests something you like better, FlashVideoReplacer would let you swap out the YouTube-provided player for either the Quicktime or VLC plugin and both should run faster than Flash or Firefox's internal <video> support.

(It also supports various players which appear in their own windows, but you probably don't want that)

Another option you could try would be to track down WHY YouTube is forcing HTML5 on Firefox by trying these one-by-one:

  • deleting all YouTube cookies (YouTube's fault but configurable)
  • running in Safe Mode to disable extensions (One of your extensions' fault)
  • using the User Agent Switcher extension (YouTube's fault, not intended to be configurable)

Finally, if none of that works, you could give Google Chrome a try. Its extension system isn't as powerful as Firefox's, but AdBlock Plus does have a version for it.

share|improve this answer
    
Chrome isn't better. Since January/February it produces many cracks in the audio output. –  panzi Apr 18 '12 at 1:46
    
Not for me @panzi –  Fogest May 6 '12 at 3:55
    
@Fogest Well, it does for me, even after installing a new Fedora version and it did when I tried it on the Mac Book of my boss (granted, he didn't reboot in many months and puts a considerable strain on his system). But even IE 8 on Windows XP and IE 9 on Windows 7 in a VirtualBox on Fedora Linux has better (crack free) audio. (Using the Media Player ActiveX element as fallback for lacking HTML5 audio.) Currently Opera has best native HTML5 audio under my Linux installation. :( –  panzi May 14 '12 at 14:37
    
@panzi Hmm that is interesting. –  Fogest May 14 '12 at 18:28
add comment

http://www.trishtech.com/internet/disable_html5_media_in_firefox.php

basicly in about:config, find and disable theese:

media.ogg.enabled, media.wave.enabled, media.webm.enabled.

share|improve this answer
add comment

If you're willing to switch to Chrome, you can use this extension, which offers the option to force a certain player type.

YouTube Options used to be able to do this but it no longer does so.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.