Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I still receive "LinkedIn Network Updates" emails even though I configured my settings to not receive them:

  • "Network activity" set to "No email"
  • "Network activity discussions" set to "No email"
  • "Top articles news digest" set to "No email"
  • "Turn on/off LinkedIn announcements" set to off

Did I miss some settings somewhere?

UPDATE

Following on from the answer posted by Barry, I received this response from LinkedIn Support:

Hi Nicolas,

Thank you for contacting LinkedIn Customer Service. I sincerely apologize for the inconvenience this has caused. Please know that we are fully aware of this issue and have a team of dedicated, highly qualified individuals who are working diligently to resolve this. As a workaround, for the time being, you can try and reset to turn on Weekly Digest Email and Save Changes, then set to No Email and save changes again.

I appreciate your patience and support as we attempt to resolve this matter.

Regards,

LinkedIn Customer Service

share|improve this question
    
I have the same problem. It seems to be completely impossible to unsubscribe to these weekly "network updates" emails. Extremely annoying. –  Oskar Aug 30 '11 at 7:31
    
Same prob here too. I have updated every email setting there is. If you google "stop LinkedIn Network Updates" you will see tons of people posting the same problem. They are deliberately choosing not to fix it. I'm a software developer ( I can send out emails from my site) and I can tell you this is an easy fix. I am going to cancel my account as I don't even use linked in any more. If their emails keep coming after that, then I'll have to add a filter to block them. It's sad that its come to this. –  MikeTeeVee Aug 30 '11 at 8:58
1  
2012 update: Apparently they have fixed the issue, I don't receive Network Updates anymore :-) –  nic Jan 4 '12 at 5:53
    
I marked them all as SPAM and deleted my account... :) Feel much better now... –  Lipis Mar 22 '12 at 10:04
    
went in and put "no email" for everything under email settings/set frequency. we'll see of that works. –  user24100 Sep 6 '12 at 14:32

3 Answers 3

up vote 2 down vote accepted

I am pretty sure you haven't missed anything. Those are pretty much the same settings that I have and I don't receive any emails from them.

You may well have to contact LinkedIn Support directly.

share|improve this answer
  1. Go to e-mail preferences
  2. Select the "Set the frequency of emails"
  3. Scroll down to Network updates and disable it.
share|improve this answer

In Gmail you can create a filter and have those emails skip your inbox and make them go straight to your Trash folder!

For creating a filter in Gmail see: https://mail.google.com/support/bin/answer.py?answer=6579

I am sure that other email applications offer similar solutions.

share|improve this answer
1  
This does not answer the question, IMO. –  Vidar S. Ramdal Nov 29 '12 at 11:27

protected by Community Sep 6 '12 at 15:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.