Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

When I go to Gmail website (FireFox, if this info is needed) with a different IP (IP from Germany), they automatically translate the page to German.

How do I stop this behavior (in other words I want English no matter what)

Like even before I login to my account, the login page is already in German!

share|improve this question

migrated from superuser.com Jun 15 '11 at 17:54

This question came from our site for computer enthusiasts and power users.

1  
Maybe better delete the google-chrome tag if it is a problem with firefox (or even when it is not browser dependable)? –  Yohsoog Jun 15 '11 at 11:42

4 Answers 4

up vote 11 down vote accepted

Add hl=en at the end of the URL, after a ? if there isn't already an ?, after & otherwise.

share|improve this answer
    
https://www.google.com/accounts/ServiceLogin?service=mail&hl=en - this link will open the Gmail login page in English. Gmail appears to ignore the hl tag once you're logged in - for that, follow Google's instructions in setting the language for Gmail. –  Jared Harley Jun 15 '11 at 19:41
    
Actually, it varies depending from which part of Google one is using. For Google Webmaster Tools, for example, the hl field is respected when one is logged in. –  JdeBP Jun 15 '11 at 21:15

Gmail language:

Under Mail settingsGeneralGmail display language choose English.

Google Chrome auto-translation:

Disable chrome://settings/advancedTranslateOffer to translate pages...

share|improve this answer
    
sry i do not mean chrome in particular. And its even before we login, the login page is already in German when i go gmail.com say with Firefox –  Pacerier Jun 15 '11 at 10:46

Use http://www.google.com/ncr to disable langage swap.
NCR=no country redirect.

share|improve this answer
1  
i wasted minimum of 2 hours, trying to get around this annoying mode of Google... and finally, THANK YOU for the solution above I can resume with more important things.. google.com/ncr works! –  user20261 May 19 '12 at 11:34

Here is a different method that worked for me, at top of email, click on "Turn off" in the translation box at the top of the message. Very annoying to continually have to work around these new "features" of Google, perhaps there is a better web based mail?

share|improve this answer
    
Do you mean that an e-mail setting will change the browser responses? –  pnuts Apr 21 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.