Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Possible Duplicate:
How to stop Gmail from serving us auto translations based on our IP address?

This is annoying me to no end.

Edit: Google is translating its pages and serving them translated. This not happening on client side (Chrome).

I live in Czech Republic and everytime I visit a Google page like gmail.com, market.android.com etc. It shows up in Czech language.

Even worse, for some reason google.cz is default search in Chrome. I would really like google.com and no other.

Even though I speak Czech it bothers me. I wonder why this is?

I have English Windows, English Regional Setttings, English Chrome. I think it looks up geographic location and sees I'm in Czech Republic.

What about people who don't speak Czech? I imagine this must be a pain.

So the question is, how do I turn translating off?

share|improve this question

marked as duplicate by ChrisF Jun 24 '11 at 12:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

You can disable it by doing:

  1. Select Options (Preferences on Mac and Linux; Settings on Chrome OS).
  2. Click the Under the Hood tab.
  3. Use the "Offer to translate pages that aren't in a language I read" checkbox to adjust this feature.

More options and how to use it can be found in Google Chrome Help.

share|improve this answer
    
nope, this is not what I meant –  Kugel Jun 20 '11 at 19:41
    
@Kugel You said: So the question is, how do I turn translating off? would you make your question a little bit more specific on what you want? –  Lipis Jun 20 '11 at 19:42
    
It is written clearly. It is google that translates pages and serves them in czech. Not Chrome browser on my side. –  Kugel Jun 20 '11 at 20:01

You can add ?hl=en (or &hl=en if there are already parameters) to any Google URL to translate it. Other than that you need to change the setting for every service you use by clicking the gears in the top right corner (works only logged-in).

If you want to change this globally you can edit your accept-language-header in your browser but I'm not sure whether Google parses this (but i suppose so).

share|improve this answer

To change Chrome's search engine to google.com:

  1. Go to Options/Preferences -> Basics -> Search -> Manage Search Engines... see here
  2. Add a new search engine and set it's URL like this http://www.google.com/search?q=%s
  3. Make it default
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.