Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

When I get emails about appointments from our Outlook server, they attach a .ics file to the email which contains the account details. This used to work fine, giving me the option to add the event to my Google Calendar.

However, now this only works if the email is sent directly to my Gmail account, and not when I use my ieee.org forwarding email address (which just forwards to Gmail).

If I send the invite to my Gmail address, the calendar event is automatically added to my Google Calendar, and I am given the option to respond in the email. In this case the raw email (without tx details) looks like this:

From: David Dean <xxxx@qut.edu.au>
To: "xxxx@gmail.com" <xxxx@gmail.com>
Date: Thu, 23 Jun 2011 09:52:36 +1000
Subject: Test
Thread-Topic: Test
Thread-Index: AcwxN3ZO6sDlD9SYT1KvfHhbcj4GVw==
Message-ID: <0A52784B9330A94A9357569C34E81F5E92C4AA80BB@QUTEXMBX03.qut.edu.au>
Accept-Language: en-US, en-AU
Content-Language: en-AU
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
acceptlanguage: en-US, en-AU
Content-Type: multipart/alternative;
    boundary="_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BBQUTEXMBX03qut_"
MIME-Version: 1.0
Return-Path: d.dean@qut.edu.au

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BBQUTEXMBX03qut_
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64

V2hlbjogVGh1cnNkYXksIDIzIEp1bmUgMjAxMSAxMDowMCBBTS0xMTowMCBBTS4gRS4gQXVzdHJh
bGlhIFN0YW5kYXJkIFRpbWUNCldoZXJlOiB0ZXN0DQoNCip+Kn4qfip+Kn4qfip+Kn4qfioNCg==

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BBQUTEXMBX03qut_
Content-Type: text/calendar; charset="utf-8"; method=REQUEST
Content-Transfer-Encoding: base64

QkVHSU46VkNBTEVOREFSDQpNRVRIT0Q6UkVRVUVTVA0KUFJPRElEOk1pY3Jvc29mdCBFeGNoYW5n
ZSBTZXJ2ZXIgMjAwNw0KVkVSU0lPTjoyLjANCkJFR0lOOlZUSU1FWk9ORQ0KVFpJRDpFLiBBdXN0
cmFsaWEgU3RhbmRhcmQgVGltZQ0KQkVHSU46U1RBTkRBUkQNCkRUU1RBUlQ6MTYwMTAxMDFUMDAw
MDAwDQpUWk9GRlNFVEZST006KzEwMDANClRaT0ZGU0VUVE86KzEwMDANCkVORDpTVEFOREFSRA0K
QkVHSU46REFZTElHSFQNCkRUU1RBUlQ6MTYwMTAxMDFUMDAwMDAwDQpUWk9GRlNFVEZST006KzEw
MDANClRaT0ZGU0VUVE86KzEwMDANCkVORDpEQVlMSUdIVA0KRU5EOlZUSU1FWk9ORQ0KQkVHSU46
VkVWRU5UDQpPUkdBTklaRVI7Q049RGF2aWQgRGVhbjpNQUlMVE86ZC5kZWFuQHF1dC5lZHUuYXUN
CkFUVEVOREVFO1JPTEU9UkVRLVBBUlRJQ0lQQU5UO1BBUlRTVEFUPU5FRURTLUFDVElPTjtSU1ZQ
PVRSVUU7Q049Y2ViaWRhZUBnbQ0KIGFpbC5jb206TUFJTFRPOmNlYmlkYWVAZ21haWwuY29tDQpE
RVNDUklQVElPTjtMQU5HVUFHRT1lbi1BVTpXaGVuOiBUaHVyc2RheVwsIDIzIEp1bmUgMjAxMSAx
MDowMCBBTS0xMTowMCBBTS4NCiAgRS4gQXVzdHJhbGlhIFN0YW5kYXJkIFRpbWVcbldoZXJlOiB0
ZXN0XG5cbip+Kn4qfip+Kn4qfip+Kn4qfipcbg0KU1VNTUFSWTtMQU5HVUFHRT1lbi1BVTpUZXN0
DQpEVFNUQVJUO1RaSUQ9RS4gQXVzdHJhbGlhIFN0YW5kYXJkIFRpbWU6MjAxMTA2MjNUMTAwMDAw
DQpEVEVORDtUWklEPUUuIEF1c3RyYWxpYSBTdGFuZGFyZCBUaW1lOjIwMTEwNjIzVDExMDAwMA0K
VUlEOjA0MDAwMDAwODIwMEUwMDA3NEM1QjcxMDFBODJFMDA4MDAwMDAwMDA2RkY0RDA3NTM3MzFD
QzAxMDAwMDAwMDAwMDAwMDAwDQogMDEwMDAwMDAwNjk5RUY3RkEzMDQyNzA0MzlBNjM4MEFCOTE4
RUVCNzINCkNMQVNTOlBVQkxJQw0KUFJJT1JJVFk6NQ0KRFRTVEFNUDoyMDExMDYyMlQyMzUyMzVa
DQpUUkFOU1A6T1BBUVVFDQpTVEFUVVM6Q09ORklSTUVEDQpTRVFVRU5DRTowDQpMT0NBVElPTjtM
QU5HVUFHRT1lbi1BVTp0ZXN0DQpYLU1JQ1JPU09GVC1DRE8tQVBQVC1TRVFVRU5DRTowDQpYLU1J
Q1JPU09GVC1DRE8tT1dORVJBUFBUSUQ6MjEwOTEyNzAyMw0KWC1NSUNST1NPRlQtQ0RPLUJVU1lT
VEFUVVM6VEVOVEFUSVZFDQpYLU1JQ1JPU09GVC1DRE8tSU5URU5ERURTVEFUVVM6QlVTWQ0KWC1N
SUNST1NPRlQtQ0RPLUFMTERBWUVWRU5UOkZBTFNFDQpYLU1JQ1JPU09GVC1DRE8tSU1QT1JUQU5D
RToxDQpYLU1JQ1JPU09GVC1DRE8tSU5TVFRZUEU6MA0KQkVHSU46VkFMQVJNDQpBQ1RJT046RElT
UExBWQ0KREVTQ1JJUFRJT046UkVNSU5ERVINClRSSUdHRVI7UkVMQVRFRD1TVEFSVDotUFQxNU0N
CkVORDpWQUxBUk0NCkVORDpWRVZFTlQNCkVORDpWQ0FMRU5EQVINCg==

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BBQUTEXMBX03qut_--

However, if I forward the email through my ieee.org email address, The only thing I see in the email is the details of the appointment in text (and sometimes not even that). I certainly don't get any Google Calendar integration. The raw text in this case is:

From: David Dean <xxxx@qut.edu.au>
To: "xxxx@ieee.org" <xxxx@ieee.org>
Date: Thu, 23 Jun 2011 09:53:42 +1000
Subject: TEst2
Thread-Topic: TEst2
Thread-Index: AcwxN52gf7e8V9MZRjux1SIjrpggsg==
Message-ID: <0A52784B9330A94A9357569C34E81F5E92C4AA80BC@QUTEXMBX03.qut.edu.au>
Accept-Language: en-US, en-AU
Content-Language: en-AU
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: en-US, en-AU
Content-Type: multipart/alternative;
    boundary="_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BCQUTEXMBX03qut_"
MIME-Version: 1.0
X-Spam-Score: undef - spam scanning disabled
X-CanIt-Geo: ip=131.181.191.3; country=AU; region=04; city=Brisbane; latitude=-27.5000; longitude=153.0167; http://maps.google.com/maps?q=-27.5000,153.0167&z=6
X-CanItPRO-Stream: ddcc (inherits from 90_OPT_OUT,default)
X-Scanned-By: IEEE Spam Scanner (https://uce.ieee.org/) on 140.98.193.230

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BCQUTEXMBX03qut_
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64

V2hlbjogVGh1cnNkYXksIDIzIEp1bmUgMjAxMSA5OjAwIEFNLTEwOjAwIEFNLiBFLiBBdXN0cmFs
aWEgU3RhbmRhcmQgVGltZQ0KV2hlcmU6IFRlc3QyDQoNCip+Kn4qfip+Kn4qfip+Kn4qfioNCg==

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BCQUTEXMBX03qut_
Content-Type: text/calendar; charset="utf-8"; method=REQUEST
Content-Transfer-Encoding: base64

QkVHSU46VkNBTEVOREFSDQpNRVRIT0Q6UkVRVUVTVA0KUFJPRElEOk1pY3Jvc29mdCBFeGNoYW5n
ZSBTZXJ2ZXIgMjAwNw0KVkVSU0lPTjoyLjANCkJFR0lOOlZUSU1FWk9ORQ0KVFpJRDpFLiBBdXN0
cmFsaWEgU3RhbmRhcmQgVGltZQ0KQkVHSU46U1RBTkRBUkQNCkRUU1RBUlQ6MTYwMTAxMDFUMDAw
MDAwDQpUWk9GRlNFVEZST006KzEwMDANClRaT0ZGU0VUVE86KzEwMDANCkVORDpTVEFOREFSRA0K
QkVHSU46REFZTElHSFQNCkRUU1RBUlQ6MTYwMTAxMDFUMDAwMDAwDQpUWk9GRlNFVEZST006KzEw
MDANClRaT0ZGU0VUVE86KzEwMDANCkVORDpEQVlMSUdIVA0KRU5EOlZUSU1FWk9ORQ0KQkVHSU46
VkVWRU5UDQpPUkdBTklaRVI7Q049RGF2aWQgRGVhbjpNQUlMVE86ZC5kZWFuQHF1dC5lZHUuYXUN
CkFUVEVOREVFO1JPTEU9UkVRLVBBUlRJQ0lQQU5UO1BBUlRTVEFUPU5FRURTLUFDVElPTjtSU1ZQ
PVRSVUU7Q049ZGRlYW5AaWVlZQ0KIC5vcmc6TUFJTFRPOmRkZWFuQGllZWUub3JnDQpERVNDUklQ
VElPTjtMQU5HVUFHRT1lbi1BVTpXaGVuOiBUaHVyc2RheVwsIDIzIEp1bmUgMjAxMSA5OjAwIEFN
LTEwOjAwIEFNLiANCiBFLiBBdXN0cmFsaWEgU3RhbmRhcmQgVGltZVxuV2hlcmU6IFRlc3QyXG5c
bip+Kn4qfip+Kn4qfip+Kn4qfipcbg0KU1VNTUFSWTtMQU5HVUFHRT1lbi1BVTpURXN0Mg0KRFRT
VEFSVDtUWklEPUUuIEF1c3RyYWxpYSBTdGFuZGFyZCBUaW1lOjIwMTEwNjIzVDA5MDAwMA0KRFRF
TkQ7VFpJRD1FLiBBdXN0cmFsaWEgU3RhbmRhcmQgVGltZToyMDExMDYyM1QxMDAwMDANClVJRDow
NDAwMDAwMDgyMDBFMDAwNzRDNUI3MTAxQTgyRTAwODAwMDAwMDAwRjU3NjQxOUQzNzMxQ0MwMTAw
MDAwMDAwMDAwMDAwMA0KIDAxMDAwMDAwMDhDNjI0RDVBRjkxRTZBNDZCNUVFM0QxREM5NTY5MDgx
DQpDTEFTUzpQVUJMSUMNClBSSU9SSVRZOjUNCkRUU1RBTVA6MjAxMTA2MjJUMjM1MzQxWg0KVFJB
TlNQOk9QQVFVRQ0KU1RBVFVTOkNPTkZJUk1FRA0KU0VRVUVOQ0U6MA0KTE9DQVRJT047TEFOR1VB
R0U9ZW4tQVU6VGVzdDINClgtTUlDUk9TT0ZULUNETy1BUFBULVNFUVVFTkNFOjANClgtTUlDUk9T
T0ZULUNETy1PV05FUkFQUFRJRDoyMTA5MTI3NjY5DQpYLU1JQ1JPU09GVC1DRE8tQlVTWVNUQVRV
UzpURU5UQVRJVkUNClgtTUlDUk9TT0ZULUNETy1JTlRFTkRFRFNUQVRVUzpCVVNZDQpYLU1JQ1JP
U09GVC1DRE8tQUxMREFZRVZFTlQ6RkFMU0UNClgtTUlDUk9TT0ZULUNETy1JTVBPUlRBTkNFOjEN
ClgtTUlDUk9TT0ZULUNETy1JTlNUVFlQRTowDQpCRUdJTjpWQUxBUk0NCkFDVElPTjpESVNQTEFZ
DQpERVNDUklQVElPTjpSRU1JTkRFUg0KVFJJR0dFUjtSRUxBVEVEPVNUQVJUOi1QVDE1TQ0KRU5E
OlZBTEFSTQ0KRU5EOlZFVkVOVA0KRU5EOlZDQUxFTkRBUg0K

--_002_0A52784B9330A94A9357569C34E81F5E92C4AA80BCQUTEXMBX03qut_--

Other than some minor differences in the name and time of the events, the main difference appears to be

--- to xxxx@ieee.org
+++ to xxxx@gmail.com
-X-Spam-Score: undef - spam scanning disabled
-X-CanIt-Geo: ip=131.181.191.3; country=AU; region=04; city=Brisbane; latitude=-27.5000; longitude=153.0167; http://maps.google.com/maps?q=-27.5000,153.0167&z=6
-X-CanItPRO-Stream: ddcc (inherits from 90_OPT_OUT,default)
-X-Scanned-By: IEEE Spam Scanner (https://uce.ieee.org/) on 140.98.193.230
+Return-Path: d.dean@qut.edu.au

If this is the difference that is causing the problem (I may have missed something, I guess), then why would the addition of these extra headers cause Gmail to not integrate with Calendar on these messages any more.

I'm also interested in what has changed, because this used to work. It looks like older emails send through my IEEE address that I know had Calendar integration at the time no longer do, so I suspect that it is Gmail that has changed, and not IEEE.

share|improve this question
    
I've had a similar mail-forwarding arrangement - I set up a rule for all meeting invitations sent to my work email address to be forwarded to Gmail. It worked a treat, and I could add those meetings to Google Calendar with a single click... until a few days ago. By letting you know that it is indeed affecting other domains/SMTP servers, I'm afraid I've reached the limit of my expertise/ability to help. I'll have defer to you as an elec engineer to investigate further! –  user11712 Jun 23 '11 at 5:54
    
Same problem here.. only a few days ago! –  user11714 Jun 23 '11 at 7:52

1 Answer 1

I kind of got this working (still working out some kinks) in Linux with the kmail client.

Any invite that I want to pop into my gmail folder.. I opent he ICS invite with "open with", and select my small bash script ~/bin/gmail-invite.sh:

#!/bin/bash

INVFILE=/tmp/tweeks.ics
DEST=email-addy@gmail.com

sed "s/old-email@work.com/$DEST/g" $1  > $INVFILE
kmail -s "New Gmail Invite" --attach $INVFILE   $DEST

Other command line mail programs (mutt?) could probably also be used. Power of the command line and all. Windows folks might be able to use a powershell script.. but the basic idea is that you replace the email address with your gmail address.. and send that to your gmail account.

Tweeks

share|improve this answer
1  
So are you saying the problem is that gmail doesn't work with invites when the email address in the invite isn't your gmail address? –  David Dean Jul 11 '11 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.