Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

When I receive an image attached to an email in Gmail I get a small preview image and View and Download links. When I click View in IE9 the image opens in a new tab but rather than it being the raw image, it is wrapped in some HTML which stops it from being automatically resized by IE9.

<html><title>photo.JPG</title><body><img src=/mail/?attid=0.2&disp=emb&view=att&th=130f139xyz963055></body></html>

How can I either stop Gmail from wrapping it in HTML (so IE9 can resize it) or make IE9 resize it automatically?

I realise that using another browser is an option but I need to find a solution for IE9.

share|improve this question
add comment

3 Answers

Click on Internet Options at the bottom of the menu. You will then see seven tabs at the top of a dialog box.

Click on the last one which is the Advanced options. Under this tap you will see lots of boxes with descriptions. Some will be checked and others not.

Scroll down to the Multimedia section. A line in that section should read - Enable Automatic Image Resizing.

check the box and click on Ok at the bottom of the window.

You're finished and can go back to viewing images in the format they were meant to be seen.

share|improve this answer
    
This doesn't work. Automatic image resizing only works if you are viewing an image directly. The problem I'm experiencing is because Google wrap the image in some HTML so Internet Explorer always shows the image at 100% of the original size. –  tjrobinson Aug 1 '11 at 11:11
    
Hi Robin, as u said this will not work. The only option is as mentioned bythe @oleschri, in the previous answer. –  Ramprasad Aug 18 '11 at 8:17
add comment

I haven't tried it explicitly on IE9 but it works on the older IEs:

Click and hold (drag) the image to the tabs bar which should open a new tab with the image's URL, therefore containing only the image without surrounding HTML.

Automatic resizing should work in this tab.

Update

After trying on IE9 myself, i must conclude the above doesn't work :( See my other answer ...

share|improve this answer
    
I tried this when I first discovered the problem and instead of doing what I'd expect it to do (as you describe), Internet Explorer prompts you to download the image file instead. I've never seen this before in other browsers. –  tjrobinson Aug 2 '11 at 12:51
    
@tjrobinson: Did you try to play around with IE9's compatibility mode? windowstotal.com/… –  oleschri Aug 2 '11 at 14:46
    
Yep, it doesn't make any difference unfortunately. I tried these modes: IE7, IE8, IE9 and IE9 Compatibility. –  tjrobinson Aug 3 '11 at 5:27
add comment

The URL from GMail somehow forces IE9 to only offer downloading the image. (Could be in its HTTP headers, didn't test that far.)

The only possible workaround is:

  • Instead of "View", use "Download"
  • Drag the downloaded Image from Explorer to IE9 to view it
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.