Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

For example, I'm searching for pages that contain the word "quiet". Google.com is happily returning hits with "quite" (and even showing them in bold!), even though that word obviously has nothing to do with the word "quiet".

I could use "+quiet -quite", but I don't want to exclude pages with "quite" -- they might be useful (if they also talk about "quiet"). I just don't want to focus on those pages.

How do you get Google to stop assuming I'm misspelling and mistyping everything?

share|improve this question
    
Can you give an example of a search, as I just tried a few and I wasn't able to reproduce the problem. Do you have any search add-ons or anything? –  jonsca Jul 26 '11 at 17:20
2  
I searched for "peopleware quiet", and hits #5 and #9 have "quite" in bold in the summary text. I don't know what a "search add-on" is. –  Ken Jul 26 '11 at 17:26
    
I run into this sometimes too. It's really annoying. Sometimes Google can be a little overzealous in its attempt to provide intelligent results. –  Anna Lear Jul 26 '11 at 17:34
    
I see what you are saying. I got one on the first page in the Amazon results. Searching peopleware "quiet" seemed to quell that one entry. And, sorry, by search add-ons I meant any toolbars or anything from Google or otherwise that might be filtering your results. –  jonsca Jul 26 '11 at 17:38
add comment

3 Answers 3

I don't know how well it works, but I found a link to this Userscript in this thread over on Google's support site. If nothing else, you can pick the script apart and find out how they did it.

share|improve this answer
    
Interesting! This just adds "nfpr=1". It doesn't seem to do anything in my case (perhaps because these two pages also have "quiet" in them, elsewhere), and it still emboldens words I didn't type, but on obvious misspellings it clearly does turn off some of the automatic spelling correction (red text at the top of the results page). I'll have to play with this some more, thanks! –  Ken Jul 26 '11 at 22:13
add comment

It looks like you are being misled by the bolding that Google is showing in the results snippet. A search for peopleware quiet does return a few results which have quite in bold in the snippet text, but in most or all the cases the page for such a result also has quite in the page text. (An exception is when quiet only appears in the anchor text of a link to the page, which Google deems a hit on quiet for the linked-to page.) The problem is that Google's bolding code always applies the "spelling correction" for determining what to enhance with bold, but this appears to affect only the snippet, not the search engine's decision to include the result in the results list.

If the bolding bothers you, you can use quotes (or, equivalently, a +) on the word, like peopleware +quiet. The snippet will not then have quiet or other variants highlighted. Note that this also has the effect of suppressing matching of synonyms. (For example, imagine song words includes hits on lyrics but imagine song +words does not.)

share|improve this answer
add comment

Putting "quotes" around the specific word you don't want Google Search to assume spelling corrections for seems to have an effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.