Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

When I created my Gmail account, I used firstname.lastname as my username.
But now I would prefer to use firstnamelastname (without the dot in between) for everything - so it's the very same username according to Gmail's own rules.

I know that this doesn't make any difference for receiving mails (I know that mails to fi.RstnAm.elAs.tnaMe would be delivered to me as well)

How do I change the sender/"from" address in Gmail?

When I send mails, the sender displayed is always firstname.lastname. I tried to set up firstnamelastname as a sender in Gmail, but Gmail doesn't let me.

The error message is:

You can't send mails from firstnamelastname@gmail.com.

Setting up different senders works perfectly with addresses from other domains (I have set up a few successfully), but apparently Gmail doesn't allow to set up different "spellings" of the same Gmail username as senders.

Any idea if this is possible at all?

share|improve this question
    
The FAQ suggests changing the e-mailadress, not adding a new send-from address. –  Legolas Aug 10 '11 at 5:57
    
Yes, but only if you want a completely different username. I'm fine with just "changing the dots". Greg's answer works for me though. –  Christian Specht Aug 10 '11 at 6:02
add comment

1 Answer

up vote 6 down vote accepted

In Gmail go to Options (cog) → Settings → Accounts

Under "Send mail as:" click on "Add another email address you own".

A popup will come out and under Email address, enter your "new" email address firstnamelastname@gmail.com and click next step.

This should close the window and now you should be able to send emails from your "modified" email address.

I've just tested it and it worked fine.

share|improve this answer
    
As I already said in my question - I tried this, and it doesn't work ("You can't send mails from firstnamelastname@gmail.com."). –  Christian Specht Aug 10 '11 at 5:52
    
Damn, you're right! It does work! The reason why it didn't work first was a different one than I first expected: I'm in Germany and here, Gmail is called Google Mail because of copyright issues (the name Gmail was already trademarked). So my real address is actually firstname.lastname@ googlemail.com, not ...@ gmail.com. For receiving mails, ...@gmail.com works as well, but apparently you can't use it as a sender. I got the error message when I tried to set firstnamelastname@gmail.com under "Send mail from another address". It works when I try firstnamelastname@googlemail.com. –  Christian Specht Aug 10 '11 at 6:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.