Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I have a Google form with a question that contains a drop-down box with the following values:

  • Fewer than 10
  • 11-25
  • 26-50
  • More than 50

If the user selects "11-25", Google Docs renders the response data like this:

ono halp

Under the formats dropdown in the toolbar, selecting "Plain Text" has the cell render as this date. Selecting "Normal" gives just "40,872", and selecting any other type of format gives "$ 40,872.00", "980928:00:00", and other various numbers that aren't anything like "11-25", depending on what option I choose.

The workaround is to change the form response option to "11-25 apples", or to recognize when manipulating my data that 11/25/2011 really means 11-25 apples. But is there a way to get Google Docs to stop turning "11-25" into a date?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

You have to format the column in spreadsheet mode before any data is entered.

Here we have a form about waffles. The cells have been formatted before sending it to the recipients.

How many waffles would you like

And here is the result after a user fills out the result.

A lot of waffles

share|improve this answer
    
Aha. Shame there's no way to fix it after the fact, but, now I know! Thanks. –  abby hairboat Aug 16 '11 at 19:57

You can also put 3 - 5 instead of 3-5. It worked for me.

share|improve this answer
    
That's a good workaround for people like me who forget to format the columns ahead of time. Thanks! –  abby hairboat Sep 25 '12 at 17:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.