Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I click on the confirmation link I get an empty page with "Internal Server Error", tried different browsers.

And: There is absolutely not possibility to contact anybody on the whole Trello homepage!

share|improve this question

This happened to me, soon after I started using Trello. It turned out that they were having "a technical problem" - 15th Sept, on Twitter - and was fixed within an hour.

However, nothing on the @TrelloApp twitter stream suggests there have been any problems today.

share|improve this answer
I registered on the 15th and tried to activate my account each day and it never worked. I also got the confirmation mail again, but this link also didn't work. – user13406 Sep 18 '11 at 14:07
Are there any non-alphanumeric characters in your name? See the "Deployed" section at the right of the Trello Development Board - it says they've deployed a fix for Can't create an account if your name has non-alphanumeric characters - maybe that bug still existed when you registered? – Clare Macrae Sep 18 '11 at 15:05
I don't have non-alphanumeric characters in my name, but they fixed it now... – user13406 Sep 24 '11 at 9:42
Glad to hear it's fixed. – Clare Macrae Sep 24 '11 at 9:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.