Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm using Google Docs to build a survey as a form for various recipients to take. The form itself is built and, as a form, functions magnificently. (Seriously, it's a work of art. I'm really good at surveys.) I'm using my Google Enterprise account to make the form and collect the data.

I had set the privacy settings such that anyone with an @stackoverflow.com account could discover the spreadsheet. When I tried to send it to someone outside of @stackoverflow.com they kept having to request permission for the file, and then she would see the spreadsheet rather than the form. I altered the privacy settings (anyone with a link can view) but I'm worried that once I start sending this to the number of people that I need to, I'll continue to have the spreadsheet-visibility problem.

How do I send out the form so that survey-takers see only the form and not the spreadsheet? Will I need to "publish to web" or alter the privacy settings further?

[UPDATE] I thought perhaps I could get around this by embedding the survey form in a website, a Google Sites page to be exact, that I made in my personal email account. However, when I tried that, copying the embed code from the app and everything, I see this:

A screenshot of Google failing me.

Which is exactly the same error I get everywhere. If it's my form's privacy settings, how the heck do I alter those? Is it because I'm on Google Enterprise? Should I rebuild this form on my personal account?

share|improve this question

4 Answers 4

up vote 6 down vote accepted

There are different ways you can view a document made in Google Apps

  1. docs.google.com/spreadsheet/pub
  2. docs.google.com/a/domain.com/spreadsheet/viewform?formkey=FORMID
  3. docs.google.com/spreadsheet/viewform?formkey=FORMID
  4. Embed on domain of application

Where 2 redirects to 3. Option 1 is most likely what you want users to see.

Option 1 is found via File > Publish to Web. Here you should see the choice to let users sign in with their domain.com account. This is greyed out but we will deal with this a little later on Thus if I am no signed with a domain.com I will get the request page. You will need to go to Form > Edit Form and change the sign-in option to view the form (not the spreadsheet). Now depending on your visibility settings you may get a pop-up asking whether the form should be seen outside of domain.com.

If you wanted Option 4, don't deselect this option. You will need to get this on the domain itself so for example domain.com/form.html. Using a Google sites for example https://sites.google.com/a/domain.com/test/ to handle the form will not work.

If you selected the uncheck the sign-in to view form, Option 3 should now work.

To get Option 1 working the admin of the Apps account needs to go in the Dashboard settings and manually enable it. Note changes will take a while to propagate, be patient with this change in the dashboard

share|improve this answer
    
I FIXED IT. YOU WERE RIGHT. THANK YOU TY TY TY. –  Aarthi Oct 10 '11 at 20:41

I found it necessary to check the "sign-in to view form" box, save, and then uncheck it and save in order to allow access to the form without sign-in (which was being required, for no understandable reason).

share|improve this answer

The newest google version has a check box on the "edit Form" page at the top, that needs to be unchecked to allow public access to the form.

share|improve this answer

You need to provide the survey takers with the direct URL to the form - don't share it via Google Docs.

To get the URL you need to:

  • Open the form in question
  • From the Form menu select Edit form

This displays your form in edit mode and the bottom of the form the link is displayed:

Forms - public URL

By sharing out the form as you did previously, you are allowing them direct access to the form and underlying spreadsheet - which is obviously not what you want.

EDIT

I have just done the following:

  • Created a new Forms document
  • Added one question
  • Renamed the form
  • Saved changes
  • Form > Edit Form
  • Copied the URL
  • Open an incognito window and pasted the URL and the form has appeared. (I am not not logged in to Google at all. The link is here if you want to test it.

The Form is set to Private and noone else on my Google apps domain has access to the document. What settings do you currently have?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.