Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

On Techcrunch or other blogs using Facebook comments, I noticed that your job title displays next to your post. Is there any way to limit the privacy settings so it only displays to friends versus public and does not show up outside Facebook?

share|improve this question

migrated from superuser.com Oct 19 '11 at 4:06

This question came from our site for computer enthusiasts and power users.

    
The only thing I was able to do was delete my job and my schooling. But I don't like it. Anyone have another solution? –  mmarchin Feb 28 '12 at 21:30
    
This has been bothering me for the better part of a day- kept thinking I fixed it, only to make a new comment and still find my job/employer info (which I'd listed as "only me" privacy). Note the key in the instructions above: after you post the comment, log-out of Facebook and then view your comment. You will notice the personal info is gone (mine just lists my city now). My employer IS INDEED available to "only me"- I just happened to be ME everytime I viewed it. –  user43685 Jul 14 '13 at 10:48

4 Answers 4

Sure. Just edit your profile (or timeline) and change the privacy setting next to your work info to "Friends". The same setting controls its visibility both on your profile and on third party sites that use Facebook Connect.

Check the comment when you're not logged in to Facebook (or from a different browser), and you'll see that the sensitive info isn't displayed.

share|improve this answer
1  
That did not work. I even tried to set it to "me only" and it still shows my title and employer in my posts. Anyone else know how to fix this? There has to be a way. I see other posters that just show city and state. –  user15424 Dec 7 '11 at 18:39
    
Could it be a caching issue? –  Al E. Dec 7 '11 at 21:25
    
It may not change immediately; try checking it the next day after changing the privacy setting. –  mark4o Dec 8 '11 at 21:37
    
Thank you. This works. If your information is set to friends, only you and your friends who visit that comment on an outside website would see the information. It is a little disconcerting, but I am glad I am the only one who can see it. –  user22016 Jul 10 '12 at 16:47
    
This no longer work anymore ?? –  Antony Lee Jul 9 '13 at 16:03

As mentioned by @mark4o, the privacy settings within the info section indeed takes care of managing your identity.

Be sure to first check whether your info is available by using the "view as" feature.

A second place to do testing is the comments plugin documentation page. Have two windows open, one as logged into Facebook the other not.

For example here is my profile set for public

Public setting

where as to friends,

Friends setting

Now writing a comment to TechCrunch

I am still logged in

Notice I am logged into Facebook so it is pulling all the information as it would be silly to hide information from myself when logged in.

Watching the same page incognito.

Incognito not logged in

You can see the comment for yourself.

share|improve this answer

I like adding a fake job description, simply to describe yourself.
I currently have something like, "all-round nice guy @ Earth", although that might come across as awfully smug. :)

share|improve this answer

Just noticed it myself. You can indeed check this in incognito modus (chrome), check what info you still see (like town, or company/work), then goto your ABOUT section in facebook and change the setting of privacy (url is https://www.facebook.com/YOURUSERNAME/info ) and change setting from 'public' into 'friends' or whatever. Then refresh the screen in chrome incognito and check what's still shown. Also change that in the ABOUT section and so on.. Mine only shows my name now!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.