Sign up ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

How do I set a different display name to show on in the revision history of a Google Docs document?

When I look at the revision history of a shared document that I've edited, all my edits are showing up as having been done by the username on my Google login email, which I want to change.

How can I change the nickname or display name Google Docs uses to label my edits?

For example, if I log into Google as, all my revisions show up as having been performed by jd1234, when I really want my co-editors to see "John Doe."

I've already tried setting a nickname on my Google+ account, and that didn't work.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Note: it will take some time for the change to propagate. For me it took about 10 minutes, your mileage may vary.

Note2: I have tested this carefully, and this worked for me at the time this was written. However later on Google has made changes to Google Docs transitioning it to Google Drive. After this, the following anonymous comment has been received: "Google Account and Google Docs are independent of each other. This change has no effect." I'm suspecting that the author of the comment means Google Drive here, not Google Docs, and that the method above may no longer work.

share|improve this answer

This is not currently possible. The Google Product forums are full of people complaining about this, too.

If you don't have a Google+ profile, it looks like it takes your Name from your profile information at

However, if you do have a G+ profile, it looks like it took your name from your G+ profile, but changing the name on your G+ profile now doesn't change the name used in Docs.

This would seem to be an oversight on Google's part, but certainly the solution in the currently accepted answer no longer works. Personal information isn't editable from the Google Dashboard.

share|improve this answer
I must add, that the account I tried it with back then did not have Google+ enabled. Can you confirm that it does NOT work even with Google+ not enabled? –  zespri Sep 17 at 19:46

protected by Community Sep 17 at 15:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.