Sign up ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Google implemented a new design for nearly all websites, including iGoogle. It now uses blue and red buttons, and the the classic iGoogle theme has grey title bars for the widgets. This new design shows up in all the browsers I've tried (IE9, FireFox 7 and 8, Chrome 15) on both my home computer and my work computer, except in Opera (10.5 through 11.6).

On Opera the search buttons are the standard browser form elements, the widget title bars are still blue and the widget menu on the left is still expanded instead of minimized. Does this only happen to me, or does Google use different styling just for Opera browsers? How can I get the new theme in Opera?

EDIT: I actually found a way to get the new design. You can identify Opera as FireFox or IE by navigating to iGoogle and performing the following actions in Opera: Opera->Settings->Quick preferences->Edit site preferences->Network->Browser identification. If you set this dropdown to 'Firefox', everything will be fine. Incidentally, this solution also fixed my problems with Google Calendar in Opera.

This all seems rather childish to me. I remember Microsoft doing this sort of thing for their MSN website. I though Google would be better than this.

share|improve this question

closed as off-topic by Al E., jonsca May 5 at 0:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on applications or application features that are no longer available are off-topic for Web Applications as no one will ever be able to make use of the answers again." – Al E., jonsca
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

Yes, Google is using different styling with Opera. I was able to reproduce your problem on Windows 7 with Opera 11.52.

share|improve this answer
Thanks for confirming. Please see my edit for a workaround. –  Bas Dec 9 '11 at 11:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.