Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

If I go to Google Plus and share a link to a question here on a Stack Exchange site, then it works and I get a preview of the question page when I compose the Google Plus post. I'm talking about a post like this one, which links to

http://serverfault.com/q/199569/14103

However, if I do the same with a direct link to an answer, then it doesn't work. An example is this post, where I tried to link to this answer:

http://serverfault.com/a/343603/14103

That showed up as a simple link with no thumbnail from the site. Does anybody know why this is so? From looking at the site with wget, both links redirect to the page with the full text.

share|improve this question
add comment

1 Answer 1

Google is unable to read the page via the short link to the answer. On first sight, the headers appear to be identical to the question short link. For the question Server Fault responds:

HTTP/1.1 301 Moved Permanently
Location: /questions/199569/where-to-maintain-central-source-repository

...but for the answer:

HTTP/1.1 301 Moved Permanently
Location: /questions/13267/git-and-mercurial/343603#343603

The only real difference is the #fragment in the redirect URL. Also, when using bit.ly URLs to test redirection with and without such fragment, Google gives the same results. So it's a Google thing.

As an aside, note that any Google tool that requests the page chokes on the short link - http://serverfault.com/a/199572:

Rich Snippets Testing Tool:

Google mobile viewer:

No good answer from Google as to why. They say it could be 'caused by an issue with web server configuration, an issue with your hosting provider or even an issue with their ISP'. Might take a question on Meta Stack Overflow to resolve?

--

Update: filed as a bug on Meta.SO.

--

Update: resolved on Google's side.

share|improve this answer
    
Hmmm. I thought I had tested the link with and without the fragment and got the same result, but I guess not. Testing bit.ly/ttA6vD [w. fragment] and bit.ly/sE65gN [w/o fragment] displays the observed behavior on G+. So it's a Google thing. –  Ciaran Dec 27 '11 at 10:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.