Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I created a Google calendar to embed on my website. I went to "Share this Calendar" and checked the following:

  1. Share this calendar with others
  2. Share this calendar with everyone my the organization

I then copied and pasted the embed code onto my website.

<p><iframe src="http://www.google.com/calendar/embed?src=hauscr.org_amh863cnb4564g11toarp9tfg8%40group.calendar.google.com&#038;ctz=America/New_York&#038;dates=20120201%2F20120315" style="border: 0" width="800" height="600" frameborder="0" scrolling="no"></iframe></p>

For 2., I selected "See all event details." Indeed, now, anyone logged in through my organization's Google apps can see my event details.

However, I also want the public set to "See all event details." Right now, all events are labeled to the public as merely "busy." The public cannot see the details of the events.

The option "1. Share this calendar with others" on the Google calendar interface does not let me select "See all event details." for the public.

Here is what I mean: Google Calendar will not let me reveal event details to the public; it's not an option in the select box:

share calendar

Does anyone know why? Thank you.

share|improve this question

migrated from superuser.com Jan 2 '12 at 6:05

This question came from our site for computer enthusiasts and power users.

1 Answer 1

up vote 0 down vote accepted

Your calendar behaves this way because of the settings in Google Apps. The default config for sharing outside of the organization is showing only free/busy information without the details. Your admin needs to change it to Share all information, but outsiders cannot change calendars or Share all information, and outsiders can change calendars in the settings page of Calendar (simply click Calendar from the admin dashboard).

You can also try setting each of your events as Public when creating them. That's the option in the Privacy control (the very last one) on the event creation page. However, this might not work because of the organization-wide setting described above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.