Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

How can I resend invitations to a shared Google calendar?

I've setup a new calendar for a non-profit organization using Google Apps for Domains. I said "no" to the initial question to send out invites because I wasn't finished tweaking it and didn't want the notice to go out until it was ready.

Now that I've finished setting up the calendar (I added a year's worth of funding deadlines, meeting dates and other important dates) I want to send out the invitations, but I haven't been able to figure out how.

The calendar is not public.

Note: This is about invites to the calendar itself, not to shared events within a calendar.

share|improve this question
    
when you click on the arrow on the right of the calendar name in Your Calendars and click Share Calendar. What doesn't work? –  JMax Jan 9 '12 at 8:42
    
@JMax, When looking at the "Share this Calendar" page there is no link or control (that I can see) to "send invitations". I can add and remove email addresses without difficulty. –  matt wilkie Jan 10 '12 at 19:25
add comment

2 Answers 2

up vote 3 down vote accepted

To share an event

You should be able to change this when you click to edit the event.

(I'm looking @ this now as I'm telling you)

Click the event you want to get to the edit page. To the right middle of the screen you can add guests and give those guest privileges. After you've enter the email(s) of the guest(s) you want to add, click add. Down at the bottom of the page is privacy settings. If you need to make the event public naturally you should know what to do.

If you click the link "Publish this event" it'll create a link you can share with others.


To share the entire calendar

If you are trying to share the entire calendar, on the main calendar page click the arrow next to the calendar and select "Share this Calendar". Follow the instructions and you should be good to go.

This link leads you to a search (through google calendar help) of sharing topics. If it doesn't help you can always search again in the search box.

Source: http://support.google.com/calendar/bin/answer.py?hl=en&answer=36598

Hope this answers your question.


How about this?

  1. Remove the person's email address (or multiple email addresses) that you want to resend it to by clicking on the trash can to the right of their email in the "Share This Calendar" tab. 

  2. Now click save at the bottom of that screen It will take you back to your home calendar screen and now all you have to do is go back in to the "Share This Calendar" tab and re-add those email addresses.  

  3. Click Save Again and now it will resend the invite to only the names you just re-added.

Source: http://www.google.com/support/forum/p/Calendar/thread?tid=229aaddb510b693b&hl=en


Another thought

Have you tried sharing the calendar ID? It's in the specific calendar's settings. It's another way to share the calendar.


(This is in comments but I'll add it here to make it easier for everyone else.)

I've found this. Not sure if you've been through it and I'm not quite entirely sure how to answer the questions so I'll pass it off to you. http://support.google.com/calendar/bin/answer.py?hl=en&answer=144119 . And I found this http://support.google.com/calendar/bin/answer.py?hl=en&answer=143754. If you read the section about sharing with specific people outside your domain, it gives what you can't give them permission to do. Like see private events.

You're going to need those "outside" people signed up for account inside your domain for this to work. It's the only way.

share|improve this answer
    
Sorry Tremaine, but this doesn't help. The calendar is already shared. To reproduce: Create a calender, share it, add an email or two, don't send invitations, save, go back to calendar share settings, add and remove email addresses. This second time there is no prompt to send invitations, at least there isn't for me. –  matt wilkie Jan 10 '12 at 19:28
    
Added a new answer under edit. Let me know. –  Tremaine Jan 10 '12 at 21:26
    
That doesn't work either unfortunately. Though it does add a a new behaviour: if the newly added address doesn't have a google account associated with it I get a prompt asking to invite them to use Google Calendar (GC generally, not this calendar specifically). If the recently re-added address does have a google account nothing happens. –  matt wilkie Jan 10 '12 at 22:00
    
I'll look again. –  Tremaine Jan 11 '12 at 3:26
    
Can I ask, are your trying to share with specific people or your entire domain? As for the prompt, I understand that happens with GTalk and their other stuff as well. They are coming on strong. Google is trying to take over the world. You should know this by now. ;-D –  Tremaine Jan 11 '12 at 3:43
show 7 more comments

What I did was remove all my guest saved and closed. Then I clicked edit event and added all my guest back in and it asked if I wanted to send invite and this time I clicked send.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.