Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Whenever I visit a new site, mostly social network or 'shop' sites, the page defaults to the French language, despite my IP being English. This also occurs when I'm on different computers, and when my cookies get wiped. I'm using Chrome.

Sites that I've mistaken me for being French so far:

  • Facebook
  • Twitter
  • Android market
  • Steam

I can't think of any others. It's often not an issue as I can change the language, but that takes time to find and change. I don't see why the internet would think I speak French, rather than English (which it should be able to pick up from my browser settings...?).

So why does the internet think I'm french?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Go to Settings -> Under the Hood -> Web Content -> Languages and spell-checker settings and make sure the first language in the list is English (or English (United States)).

enter image description here

If you don't have it in the list, click Add to add it.

enter image description here

enter image description here

Webpage language preferences help Google Chrome determine the language it should use to display a webpage. To adjust your preferences, first click Languages and spell-checker settings to open the "Language and Input" dialog. Add or remove languages from the list, and drag to order them based on your preference.

From the Google help page on how to Adjust fonts, languages, and encodings (under Webpage language preferences).

share|improve this answer
    
English (United Kingdom) was the first option, and was selected. The second was French. Why wouldn't it use the first choice? –  Pureferret Jan 21 '12 at 12:34
    
Probably because of your system default language. –  Alex Jan 21 '12 at 12:39
1  
My system default language is English (United Kingdom) though....is it possible that the sites don't recognise the (United Kingdom) section? –  Pureferret Jan 21 '12 at 12:48
1  
I'd say better to remove French (unless you need it, of course) or set the language to general English. I'm talking about the settings in Chrome, not the system. –  Alex Jan 21 '12 at 12:56
1  
@Pureferret: Likely, the site doesn't have a UK English version, so it goes to your next preferred language, which is set to French. You probably want to add 'English' and 'English (United States)' to your list, before French. –  derobert Jan 24 '12 at 21:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.