Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

One of the things that drives me nuts on Facebook is that links to Washington Post articles aren’t real links — clicking on one yields not the web page in question but an invitation to install the Washington Post Social Reader app, which I want no part of.

It turns out that one doesn’t even have to install the app to make this happen. For example, I posted this link earlier today. I've never installed the app. Yet clicking on the link has the same undesired behavior (install app, not follow link).

How do I make this obnoxiousness stop, and simply post unadorned links to Washington Post articles to Facebook?

share|improve this question
    
FWIW, I tried a couple of URL shorteners (bit.ly, tinyurl.com) and that didn't solve the problem. –  Reid Jan 29 '12 at 17:44
2  
Maybe they just don't want people to link to their articles and eventually, reading them –  Eight Days of Malaise Jan 29 '12 at 18:19

2 Answers 2

Eight Days of Malaise's answer seems to be the easiest solution to this, getting to the meat of the content.


Initially I would just say to block the app but, I've just realized Facebook is phasing out app profile pages which makes it more difficult to block an application. It seems that Facebook is saying it will only work before the app request or if you did not install it.

Click the Block App link in the left column

But this is not true.

From what it works for me, simply removing the application, then clicking "Recommend" seemed to do the trick, no app request was initiated.

No WPSocial

Though when retrying a request to the WPSocialReader, if one cancels the request, the user is redirected to http://www.washingtonpost.com/ instead of Facebook home page http://facebook.com which I assumed would be the default behaviour after denying a Permissions Request (though they did state "click cancel to bypass"). Then again inspecting for a specific link

Specific Link to an article

This works in your favor as you are redirected to the page when clicking cancel.

Now going back to first original share and clicking on it does seem to indicate Washington Post hijacking my links as they are indirectly letting themselves be endorsed through my links. On any subsequent request, the redirection goes straight through to Washington Times though.

The cookies are being saved here http://wpsocialreader.washingtonpost.com/ so that any subsequent request goes straight for redirection instead of the app.

Without

  • sharing an extension/userscript with your friends that links directly to the respective Washington Posts articles
  • setting the cookies for wpsocialreader.washingtonpost.com

there is nothing you can do for your friends.

For just you, simply cancelling the app request should work as long as you don't clear the cookies for wpsocialreader.washingtonpost.com.

share|improve this answer
    
Hmm, it sounds like everyone who clicks on the link will have to do this? My goal is to not subject all my friends to the app or a workaround -- I want the link to just be a link. –  Reid Jan 29 '12 at 5:38
    
@Reid As I said in the top, Eight's answer should suffice. I have tried it and there are no redirects. –  phwd Jan 29 '12 at 5:41

Find and share the print version of the article instead.

It's still the same article, just with a lot less advertising and a bare bones layout designed for the printer.

For most sites that have their social app tied into their website from Facebook referrals, you should be able to get around the prompt to install via this method.

That is until they start bugging you with the app if you link to a print version.

share|improve this answer
    
Doesn't work in this case, unfortunately. Still wants me to install the app when following the link. –  Reid Jan 29 '12 at 17:39
    
Maybe it depends on what browser you are using but I have tested this link http://www.washingtonpost.com/blogs/ezra-klein/post/the-incredibly-shrinking-bi‌​ll-for-tarp/2012/01/26/gIQAMkh8SQ_print.html multiple times and it has never prompted the app. Sorry to hear it doesn't work for you. @Reid –  phwd Jan 29 '12 at 18:02
    
@phwd, I wonder if it's a cookie thing? I hear that if you hit "cancel" once on the app invitation screen, it stops inviting you. Does the prompt still fail to appear if you clear cookies and try again? –  Reid Feb 1 '12 at 17:24
    
@Reid If you hit "cancel" and clear the cookies the app prompts again. If you don't clear the cookies and hit "cancel" the app will not prompt you again. –  phwd Feb 1 '12 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.