Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I keep my Google account permanently logged in here at home. Every once in a while, when I open my browser I am greeted with a log in page like this one:Pre-filled login.

I'm not complaning about this, of course Google should ask for my password every once in a while, and it's very kind of him to have already filled-out my username.
The problem I have is that this page simply doesn't work. I have no idea why. I've tried typing my password 15 times in a row, taking the greatest care to hit all the right keys, but it always says Username or password incorrect.

Please don't tell me to check my CapsLock or my NumLock. I know the problem is with this page. The regular login page (the one where the username is not filled in) works perfectly fine, but this specific page never works.
It's happened dozens of times:

  1. Google shows me this page;
  2. I try typing my password a few times;
  3. I give up, manually go to Google.com, and log in with the regular log in page.

This has been driving me nuts! Why does it happen? Can I fix it? Is it a bug?

EDIT: Ok, I'm just editing because I've managed to pin it down a little bit better, and I think I can reproduce it reliably. I keep both Google Reader and Gmail tabs permanently open, whenever google decides to ask for my password again, it does so on both at the same time (using the prompt shown above).
The problem happens after I login with one of these tabs. The other tab then becomes impossible to login, but it also doesn't update accordingly. Refreshing the page or hitting the Back button don't help either, I'm forced to manually type in the base url for GoogleReader.

Note that this is only one version of the problem (which I've managed to reproduce). Another version also happens with the computer at work. It is described above (before the edit) and is a little more annoying because I'm forced to login manually and doesn't involve 2 simultaneous tabs.

share|improve this question
    
What is the page url? Could it be phishing attempt - some addin / virus changed your home page or something simmilar? –  YetAnotherUser Feb 23 '12 at 22:57
    
@YetAnotherUser I can't remember exactly, but I'm positive it's a google domain (I've worried about this before). Plus, it happens on three different machines, both on Windows and Linux. –  Bruce Connor Feb 23 '12 at 23:13
    
@YetAnotherUser I can't check the URL right now. I have to wait until it asks for my password again. =) –  Bruce Connor Feb 23 '12 at 23:14
1  
Hmmm! Is your normal login domain a regional one - i.e. the one that works is that accounts.google.se or similar? As this happens on different machines shouldn't be due to corrupt cookie but it doesn't hurt to try clearing cache and see. –  YetAnotherUser Feb 24 '12 at 14:17
3  
@YetAnotherUser It's actually the same domain (accounts.google.com). But now that you've mentioned it, all Google pages (including the normal login) are in English for me. The pre-filled login page is the only one that's in Portuguese. That might me causing some sort of settings/cookie conflict. –  Bruce Connor Feb 24 '12 at 21:26
show 5 more comments

1 Answer

I sometimes have a similar issue. I believe this happens when you indeed use different Google services at the same time, and from time to time switch accounts on a service. Then the other service on a different tab seems to get confused.

Try clearing all of the *.google.* cookies of your browser.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.