Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Google Maps used to show street names, all the way down to minor back roads if you zoomed in enough. Now, those seem to be gone. Is is possible that I've accidentally changed a setting that displays street names, or is this some bewildering new "feature" of some sort?

In response to the comments, here's a screenshot:

enter image description here

...and my browser info:

Google Chrome 18.0.under Mac OSX 10.6.8. Street labels sometimes appear at different zoom levels, but not always.

share|improve this question
3  
I still see street names. Can you give a screenshot or link to a specific map where you see this problem? –  William Jackson Mar 30 '12 at 20:48
    
Agreed, like @WilliamJackson, I can see street names. More info will be needed to troubleshoot this problem. –  JW8 Mar 30 '12 at 23:16
    
Disable WebGL maps. –  dnbrv Mar 31 '12 at 5:05
    
@dnbrv - How do I do that? –  neilfein Mar 31 '12 at 15:21
    
@neilfein: Open Google Maps and look at the bottom of the sidebar on the left. –  dnbrv Mar 31 '12 at 15:38
show 2 more comments

4 Answers 4

up vote 2 down vote accepted

Judging by the screenshot (the zoom slider), you have WebGL enabled. It renders the visuals slightly differently and might bring some artifacts. (On my computer, the loading/rendering process looks strange but the end result is always working fine.)

To turn off WebGL in Google Maps, open the site and look at the lower left corner of the screen (bottom of the side bar). There's the button labeled Classic - click it.

enter image description here

Note that disabling WebGL will also disable some of the features, such as 3D buildings and 45° imagery.

share|improve this answer
add comment

Block your Flash player plugin on Google maps, in Firefox next to the back button.

share|improve this answer
add comment

For the updated Google Maps (2014), opt to go back to the old Google Maps. Click on the little gear looking icon at the bottom of the screen.

share|improve this answer
add comment

It's now called ROADS and is a LAYER - Usefully it's turned off. You dont need to lose Glide (but I prefer it without anyway)

share|improve this answer
    
I'm not seeing a "Roads" layer. The "Labels" layer removes street names when using the Satellite view, but on the Map view the street names are there by default and "Labels" can't be de-selected. –  Al E. Aug 16 '12 at 17:37
    
My experience is the same as @AlEverett - DAve, can you post a screenshot of this on your end? –  neilfein Aug 16 '12 at 19:10
add comment

protected by jonsca May 5 at 20:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.