Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I have setup email with my domain in Google Apps, but when I did, I did something they asked to protect me from spam mail. (I guess I added some TXT or MX records.)

But now I miss a lot of email because Google thinks they are spam!

I want to remove this settings and I don't have any idea what to do. I checked my MX and TXT records but couldn't find anything understandable. I also checked the dashboard of Google Apps.

share|improve this question
add comment

3 Answers 3

up vote 0 down vote accepted

The DNS record that Google had you add "to prevent spam" is a type of TXT record called an SPF (for "Sender Policy Framework"). However, it has nothing to do with email that you receive, only email that you send. The SPF basically tells other email servers that only certain locations are authorized to send email on your behalf, in this case, only Google servers. Wikipedia has a good explanation of SPF records.

There are several possible reasons that email would not come to your Inbox or Spam folder.

  • You have forwarding to another address set up. You may also have it set that after messages are forwarded, they are archived or deleted. Check your All Mail and Trash folders to see if there are messages there.
  • You may have a filter that is deleting or archiving some messages. To check this, go to the Settings page and open the Filters tab.
  • It is possible that mail is not reaching Google's servers. This could be due to several things, including a typo in any of your DNS records, an old MX record that was not removed when you set up Google Apps, or possibly some other reason.

None of these cases has anything to do with Google's spam filter. As far as I know, Google does not make decisions about putting mail in your spam folder or throwing it out. I think that they put it all in the Spam folder and let you handle where ti goes from there (or it gets deleted automatically when it has been there for 30 days).

share|improve this answer
add comment

To fix:
Go into your mailbox's "Spam" folder and select all those non-spam messages, then click the Not spam button. Gmail will learn from this and sort your non-spam better in the future.

Background:
The DNS records for MX and TXT don't relate to the handling of spam:
The MX entry simply tells other mail servers that mail to you should be routed to Google.
The TXT entry is your proof to Google that you're the real owner of the domain.

share|improve this answer
    
but I dont recieve any email in my spam folder too. and I'm sure I have added a record after my mail is working to prevent spam –  pahnin Apr 12 '12 at 7:33
add comment

If there is mail from a specific user or specific domain that you think you are missing then adding that to your whitelist (mail that you always trust) is an option. To do this in Gmail:

  • Go to Settings > Filters
  • Click Create a new filter.
  • Type the required email address under From:.
    • To whitelist an entire domain just enter the domain name or the domain name preceded by '@'. To whitelist "example.com", for instance, type "@example.com".
    • You do not have to create a separate filter for each address. Use '|' in the From: field to enter a list of addresses or domains. To whitelist both "john@example.com" and "jane@example.com", type "john@example.com|jane@example.com".
  • Click Next Step ››.
    • You can click Test Search to double check you've entered the correct information
    • Make sure Never send it to Spam is checked.
  • Click Create Filter.

Now all e-mail from those domains/addresses will be delivered regardless of whether the system thinks they're spam or not.

Source

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.