Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

It drives me crazy that I get notifications from people I don't know who have written on the wall of an event that I (along with 3000 other people) was invited to.

I see that you can prevent getting emailed whenever this happens, but is there way to avoid the notification (i.e. the red "globe" with the number lighting up) entirely?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Yep! For Facebook's Notifications on a specific event, here's how to turn them off.

  1. Go to the event page.
  2. Click the "Gear" icon in the upper right.
  3. "Turn off Notifications"

Also related, to disable Email Notifications for events (every event, not just a specific one)

  1. Go to your "Account Settings"
  2. "Notifications" from the left
  3. Under "Events" uncheck "Posts on the wall of an event you've joined"
share|improve this answer
2  
Thanks - I think the first method (per-event) will work, but I'm pretty sure the second method (for all events) only controls whether you get an email or not, though I could be wrong. I already had that unchecked but still get the "within facebook/red globe" notifications. We'll see if the per-event method works though... –  Jer Apr 25 '12 at 20:02
2  
Ah, I do believe you're right, that the second part is for email only. I've edited my answer to reflect that. –  JonathanMumm Apr 26 '12 at 22:05
    
That doesn't work anymore. There isn't a gear icon on the event. –  user34894 Feb 19 '13 at 13:18
    
Marianna, the gear is still visible on every FB event I've joined, and the option for "Turn off Notifications" is also there. –  JonathanMumm Feb 22 '13 at 7:49
add comment

Indeed, to get the gear, one must first select Going.

Unfortunately, even after selecting Stop notifications within the event, they still keep coming.

Also, regarding the original suggestion: There simply is no Events option in the FB general Notifications controls, only a Group option.

share|improve this answer
add comment

There is no gear icon if you Declined the invitation. There is an issue with FB. You have to say that you are Going to see the gear icon and turn off notifications. I'm sure Facebook is getting complaints about this and will fix it soon. It JUST started happening to me recently and it is insanely annoying.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.