Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

On my primary calendar on Google Calendar, any time I create an event, the event time gets moved to 3 hours prior to the time I specify. This does not happen immediately, but after a short time (e.g. an hour).

Things I have noticed:

  • All-day events get changed to 9:00pm - 9:30pm the day prior.
  • All non-all-day events simply have their start and end time shifted back 3 hours.
  • This only happens to events on the PRIMARY calendar (I know of no way to delete the calendar entirely, or to change the primary calendar).

I have gone through all settings related to my Google account, Google Calendar, and the specific calendar, and verified that all timezones are set properly to "Arizona" time (no daylight savings, currently GMT-7:00 Mountain Time. I have no devices set up to sync with the calendar (I simply access from https://www.google.com/calendar/render).

In addition, I have deleted all events on the calendar, and there are no events that are shared by any of my calendars (though I have set up 3 "Interesting" calendars -- Weather, US Holidays, Friends' Birthdays).

My current resolution to this issue is to rename the calendar to 'DO NOT USE', but given that this is the primary calendar (default for all events, unhidable, and at the top of the list), it is rather annoying.

My question is how can I resolve this problem? I am looking for an answer that will tell me any of the following:

  • How can I change the primary calendar?
  • How can I delete the primary calendar?
  • How can I resolve the time-changing issues with the calendar?
share|improve this question

migrated from superuser.com May 2 '12 at 5:56

This question came from our site for computer enthusiasts and power users.

    
Timezone changes are causing it. You have one timezone set on your calendar, and whatever you're syncing with thinks it's another timezone, probably GMT. –  user3697 May 2 '12 at 5:47
    
There are timezones on events as well. Have you checked those? cl.ly/1s0y2x2i1E2n161J2n2m –  Dez May 2 '12 at 6:05
1  
My phone is out of the equation, since it's been happening since before I had it. I have not synced with any other device, and all computers I've used have the correct timezone. @Dez Without making it all day, events default to the right timezone. Choosing all-day for an event removes the time zone option. –  Darthfett May 2 '12 at 13:06
    
Are you sure that you have set the same time zone in your Google Account, Google Calender Settings, The particualr Google Calender in Question, the particualr event in question, your mobile phone? –  user221287 May 2 '12 at 18:48
1  
Are you absolutely sure you are not syncing with anything? Like iCal on your Mac, or other desktop calendar software? If not, I would file a support ticket with Google for this, as it is certainly not right. –  Vidar S. Ramdal Oct 22 '13 at 14:19

1 Answer 1

It's a time zone conflict between your Google Calendar and the devices you sync it with. I had the same problem. One of my devices didn't have Daylight Savings set, and after syncing it would send a different time back to the Google servers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.