Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know how to do this in Google Spreadsheets, but it seems there's no data moving support for tables in Google Documents at all. (I can't even select in columns)

Does anyone know how to do it?

share|improve this question

migrated from superuser.com May 25 '12 at 13:11

This question came from our site for computer enthusiasts and power users.

up vote 2 down vote accepted

I've tried a lot. You can't move the columns of a table in the Documents of GDocs. However, if you create a column to the left or right or where you want the new column, you can then select the content from the column you want to move, copy, then, and this is important, you have to select the whole new (blank, newly created) column from top to bottom, and paste the material there. Then, delete the old column and the table will re-format the size. Good luck!!

share|improve this answer

I was unable to move it at first, but if I double click on column name and drag it, I could see a black line border at the left edge of the column and when I drag it across the other columns, I was actually able to move it.

share|improve this answer
I think you're talking about Google Spreadsheets. I have no trouble moving columns there. The problem is with Google Documents where I cannot even select a whole column. – billc.cn Nov 24 '13 at 12:14
aren't they both same? – pahnin Nov 25 '13 at 15:10
You certainly won't consider Excel and Word the same application, will you? – billc.cn Nov 25 '13 at 16:10
Okay, so you have a column in document writer, I get it now – pahnin Nov 26 '13 at 7:28

I've just checked and selecting both row and columns is allowed. Right clicking over selected column (or row) shows cut, copy, paste an a few other options. You should check any restriction on your web browser. Maybe trying with another one.

share|improve this answer
Tried Firefox and Chromium under Linux and neither of them supports column selection. Are you sure you did it in document as opposed to spreadsheet? – billc.cn May 24 '12 at 17:27
I'm positive on a Windows enviroment, since I don't have any Linux desktop around I can't test it. Do you have the same problem using the live demo? google.com/google-d-s/spreadsheets – beiro May 25 '12 at 7:31
That's the 'spreadsheet' app of Google Docs. I am using the 'document' app... – billc.cn May 25 '12 at 8:27
You should try clearning your cache and trying again. I know that I used to have problems with Google Docs in linux and I needed to clear my cache often. It also could be an issue with the size of document combined with the OS. – Dez May 25 '12 at 13:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.