Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

Does anyone know why I can't highlight text when visiting Snopes.com? Give it a try and see if it works for you - This is something that happens on every computer I've visited Snopes from, if I had to guess I'd say 3 or 4, in both Windows and Linux, Firefox and IE.

It's not the main screen, but if you view a topic and/or a legend (any of them, they all do it) you'll see what I mean. This has bothered me for a couple of years now, and I know its not specific to my computer...I just want an explanation as to why.

share|improve this question
1  
Works for me. WinXP, Firefox 3.6. Perhaps it is highlighting but the CSS is odd enough to keep it from showing. What happens if you turn off CSS? –  Al E. Jul 9 '10 at 19:34
    
By the way, snopes is by no means a web application, so is technically off-topic. –  Al E. Jul 9 '10 at 19:34
    
Yes, but doesn't fit into the scope of the other sites, so I put it here for lack of a better place. –  Mistiry Jul 9 '10 at 19:41
1  
Not ideal, but you can right-click on the page and view the page source if you absolutely have to copy/paste the content. You'll have to filter out the HTML, but the content is there. –  squillman Jul 9 '10 at 19:44

6 Answers 6

up vote 8 down vote accepted

Looks like they have some script mayhem specifically preventing it.

Check this out when viewing the source:

<script type="text/javascript"> 
<!--
var omitformtags=["input", "textarea", "select"]
omitformtags=omitformtags.join("|")
function disableselect(e){
if (omitformtags.indexOf(e.target.tagName.toLowerCase())==-1)
return false
}
function reEnable(){
return true
}
if (typeof document.onselectstart!="undefined")
document.onselectstart=new Function ("return false")
else{
document.onmousedown=disableselect
document.onmouseup=reEnable
}
-->
</script>
share|improve this answer
    
Thank you, this explains why it happens. –  Mistiry Jul 9 '10 at 19:43
    
Good catch. –  Al E. Jul 9 '10 at 20:08

Because the want to protect their content they do not want it to be easy for someone to take their articles and repost them elsewhere as their own. They want you to share links rather then the text.

share|improve this answer
    
Right Click > View Source > Copy the text I want...Pretty easy...If they were worried about copyright infringement, I think they would have right-clicking disabled as well. –  Mistiry Jul 9 '10 at 19:43
    
@Mistiry that's true, but a lot of more naive users who don't know about View Source might just try to copy text to their friend, then give up and use the link when they find it doesn't work. –  NickAldwin Jul 9 '10 at 20:53
    
If people seriously want to do that, they can easily do so. The effect for me was that I could highlight and "Search Google for '<marked>'" in Chrome... make it not harder for actual thieves in any way, but pissing off everyone else. –  Jürgen A. Erhard Jun 21 '13 at 21:11

I found it easier to just click on edit-->Select All. Copy that, paste it into Word (this might take a couple of minutes), then you can easily copy/paste the text you want without having to worry about all that HTML stuff.

Cheers.

share|improve this answer

While you are on a webpage on that site with Firefox, go to the Tools menu, select Options and in the dialog box that opens, select the Content tab & there uncheck the checkbox next to Enable JavaScript option to turn off JavaScript & overcome this constraint.

Other browsers will also similar ways to disable JavaScript.

share|improve this answer

Use the Enable Right Click Bookmarklet. Googleable. or just paste this into the address bar and hit Enter.

javascript:void(document.onmousedown=null);void(document.onclick=null);void(document.oncontextmenu=null);
share|improve this answer

As Dillie-O mentioned, they intentionally prevent text selection. This is annoying for those of us who select text as we're reading.

Getting around this is easy--just paste the following into your browser's javascript console:

document.onselectstart=null;
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.