Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I don't want one of my friend's content to appear in my Facebook news feed. How do I remove it? I tried clicking the arrow button and "removing from feed" but it still shows in my feed daily!

I even doubled check this. If I click on the "Friends" button on their main page, it says "Show in news feed" unchecked. But it still shows! What gives?

share|improve this question
    
Are you using the web interface or an app? Some apps for Facebook have very limited controls (I hate the iPad version, for example). The web interface running on a popular and modern browser (Chrome, Firefox, IE9) provides the best way. Apps have to be udpated/released/etc. whereas the javascript in the web version just gets loaded dynamically when you visit the site. –  Fuhrmanator Jul 2 '12 at 18:43
    
I'm using the full web version in Safari on the desktop. –  erotsppa Jul 2 '12 at 22:50

4 Answers 4

Recently added1: Simply go to your friend's profile and click the "Following" button (so that it now reads "Follow"). (You can also do that if you hover over their name in your feed.)

Now you can be friends with them but their status updates won't appear in your feed. (It may take some time for content that's already there to age out.)

share|improve this answer

Here i found the link via facebook http://www.askmehow.in/15/how-to-bulk-disable-all-facebook-friends-news-feed about how to disable the facebook news feed in bulk or selectively. It does the trick.

share|improve this answer
1  
Please include the necessary steps in your answer. If the page you're linking to goes away, the answer will be left useless. –  Vidar S. Ramdal Jan 8 at 16:23
    
Did seen the above post? Its fairly simple. Which point you did not understand? Let me explain u. –  Niraj Jan 8 at 16:26
3  
@Niraj: The point is, if that link no longer functions, your answer here then contains no useful information. We like answers to be self-contained. –  Al E. Jan 8 at 17:28

Facebook's help says you can unsubscribe from someone. This works for me.

share|improve this answer
    
I followed exactly that instruction and my friend still shows in my news feed. –  erotsppa Jul 2 '12 at 22:50
    
@erotsppa It's a glitch. Give it some time. If it doesn't fix itself, try the operation again. –  dnbrv Jul 3 '12 at 0:33

In the left column, where your different groups and pages are listed, right on top there's News Feed. You can see and edit your settings there. Only the friends/pages/groups you've unsubscribed/selected hide content are listed there. And this works fine.

enter image description here

share|improve this answer
    
I clicked that, and in the popup it says "Hide posts from: " and that friend shows in that list. But still her post still shows in my news feed. Whats going on? –  erotsppa Jul 2 '12 at 22:50
1  
Well, that's really strange. This should have worked. I'll try to figure out the problem. –  abhshkdz Jul 2 '12 at 22:52
    
Any ideas? Could it be because I have too little friends? –  erotsppa Jul 3 '12 at 2:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.