Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

In the last few days, I've started getting Facebook notifications both in the web app and on iOS for some status updates or photo uploads from friends.

The notifications have a star icon and the URL includes notif_t=top_news_story, suggesting I get notifications for "top stories".

I would prefer it the way it was before, where I only get notifications for comments on my stuff, when I'm tagged in a picture etc.

I haven't yet found the setting to disable this. Anyone?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I came here looking for help on this same issue and instead found the answer myself and thought I would share:

  • Click on the "Notifications" button / icon at the top left of your profile (third button to the right of the FB logo).

  • Hover over the offending notification and an "x" will appear at the top right of the said notification.

  • Click on the "x" ("Turn Off") and you will be asked to confirm "Turn off top friend activity notifications"

The End

share|improve this answer
    
Good work! Thank you. Will have to wait a while to see if it had the desired effect, but I would be surprised if this doesn't do it. –  Henrik N Jul 19 '12 at 16:58

On your Facebook homepage, on the bottom left, under the friends tab, click on Close friends. It won't show any friends if you haven't added any. What I did was I clicked x for every friend in the suggestions on the right and on the top right where there is a notifications tab. I chose off in the drop down menu.

share|improve this answer
    
Thank you! To clarify what you meant by the "friends tab", here are Facebook's instructions which you helped me find: facebook.com/help/?faq=112320895539157 It also doesn't list any friends for me, but I'll try turning off notifications on that page and see if that solves it. The ones I did receive notifications for are some of the ones it suggested. –  Henrik N Jul 10 '12 at 5:58
    
Seems just turning off the notifications wasn't enough. Also removed the suggested friends, now. Let's see if that works. –  Henrik N Jul 10 '12 at 15:38
    
Just got another notification despite doing both things described above :/ So either that's not enough, or there's a delay until it takes. –  Henrik N Jul 10 '12 at 20:23
    
It worked for me. Hopefully it is just a delay and works for you soon enough. Do you by any chance have Facebook Mobile Texts activated? I am also having issues with that and was wondering if others did as well. –  shehz Jul 11 '12 at 4:45
    
Thanks again – will have to wait and see. Don't have Facebook Mobile Texts active, unless it's on by default. –  Henrik N Jul 11 '12 at 21:17

You can edit notification settings from within Facebook.

Facebook Notification Settings

Hope this helps.

share|improve this answer
    
Thanks! I did look in those settings but didn't find anything that seemed to apply to this. –  Henrik N Jul 10 '12 at 5:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.