Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

When I try to view a public document (example found on the net) with my Google Apps account I get this screen:

Google Drive. You need permission to access this item.

Clicking on the button will send an email to whoever created it, and then I have to wait for them to give me permission.

On my standard Google Account, I can view public documents straightaway.

Why is this?

Note: I have my Apps account set up to use Docs, and have been using them myself.

Edit: I tried in another browser, without even being signed in I can view these docs.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted
+50

Your Google Apps admin has not allowed users to receive documents from outside your domain.

One of the sharing options you can set for Docs & Drive within a Google Apps account is weither or not users can share documents to people outside the organisation. One sub-option of this is that they can separately allow or deny users from receiving outside documents

As the administrator, you determine whether users can share their Google Docs (documents, presentations, spreadsheets, and drawings) outside your organization, whether they can access docs created outside your organization, and the default visibility level for new docs.

Google Apps admin Document sharing options


If you are the administrator of the domain you can change the settings via:

  1. Sign in to the Google Apps administrator control panel.
  2. Click the Settings tab and then select Drive and Docs in the left column.
  3. In the Sharing options section, choose whether users can share docs outside your organization.
  4. Hit Save

I'm not sure if this is on or off by default but just ask your admin if they can allow outside sharing. Worst case is they will say no because of X.

share|improve this answer
add comment

Unexpectedly last week, my visitors couldn't access my public docs. I verified had "Users can share". Was still getting errors.

My solution was to:

  1. Select Users cannot share.
  2. Save.
  3. Select Users can share.
  4. Save.

This was enough to fix the permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.