Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I'm an admin of several pages on Facebook (for technical stuff like RSS imports, etc.), but neither do I contribute content nor do I care about their content.

Still, as an admin, I get notifications (upper left hand, the globe icon) about activity (someone liked this, someone posted that) on those pages in my personal (!) profile .

Does anyone have the same issue? Is there any way to explicitly disable notifications for certain pages?

(This behavior seems to be new, by the way; I'm only seeing those notifications for a few weeks now.)

share|improve this question

migrated from stackoverflow.com Aug 12 '12 at 3:13

This question came from our site for professional and enthusiast programmers.

    
I'm admin of two pages, but I only get notifications (on-site) from one. I don't know how I disabled that and I'm still trying to find out. –  user23333 Aug 15 '12 at 4:19
add comment

2 Answers 2

The page notifications do appear under your personal-profile globe icon if you set using your page as you personally. If you return to using your page as your page, the notifications will appear only if you use the whole Facebook as your page.

share|improve this answer
    
I have since removed myself as admin from these pages, however, I vaguely remember such a setting somewhere. If anyone having the same problem confirms this as solution, I'll put yours down as best answer. –  pulsar Aug 22 '12 at 7:54
add comment

A few things you can try:

  1. Visit https://www.facebook.com/pages/edit/?id=[PAGE-ID]&sk=yoursettings Replace [PAGE-ID] with the ID of the page you're getting updates from. Make sure both of the check boxes on this page are not checked. (They are checked by default).

  2. You should also visit https://www.facebook.com/settings?tab=notifications&section=Pages&view and click the "Pages" item to expand it, then click on the "Change email settings for individual pages" and uncheck the boxes pages you don't care about.

  3. On your news feed, click the down arrow in the upper right of the div containing a story from a page you don't care about and select "Hide all by [page name]".

share|improve this answer
    
Thanks for your answer! However, points 1 and 2 relate only to e-mail notifications, not on-site notifications (and all checkboxes are already disabled anyways). Point 3 relates to the news feed, but I don't see any content from the mentioned pages there. I was referring to the globe icon in the left hand side of the top toolbar. –  pulsar Apr 30 '12 at 16:41
    
As far as I can see, to Facebook, there is only one notification setting that handles emails and the "globe icon" notifications. Click the Globe icon, and go to "Notification settings" and it takes me to the same dialog in my point 2 above. –  cpilko Apr 30 '12 at 16:54
    
Of course, YMMV. I've seen where my Facebook interface and menus are completely different than my wife's on the same PC, browser, network, etc. –  cpilko Apr 30 '12 at 16:56
    
Has Facebook changed again? I can’t find any settings anywhere controlling what notifications appear under the globe icon (and push to my phone!) All I can find is the email settings (which are greyed out?) –  DouglasHeriot Jul 13 '12 at 11:05
2  
Point 1 did it for me, it had check boxes for both email and site notifications for events relating to the page. –  matt Oct 31 '12 at 14:49
show 1 more comment

protected by Community Aug 29 '12 at 15:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.