Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I import mail from another mail account/server into my Gmail.

I do not want to save a copy on this other server. I went into Gmail settings → Accounts and clicked edit info next to my external account and made sure that the box was unticked.

But it still saves a copy on the other server and now it's dangerously filling up that mailbox. Any ideas on how to truly delete that other copy on the other server?

share|improve this question

migrated from superuser.com Aug 17 '12 at 6:09

This question came from our site for computer enthusiasts and power users.

1 Answer 1

up vote 4 down vote accepted

Gmail imports emails from other accounts via POP, which doesn't sync email states. Though Gmail asks the other domain not to retain the copy, ultimately, it's up to the other domain:

Gmail will instruct the other domain to leave the messages in place, though the final behavior is up to the other domain.

Your options include:

  • Manually delete the emails from the other server.
  • As JMax mentions, some servers have the option of "Autodelete after x days", worth investigating that.

Although I should point out that Gmail itself doesn't seem respond to the "delete from this server" option.

share|improve this answer
    
The other option is to change settings on the other web account (something like "Keep messages on server for X days") - nice answer and +1 btw –  JMax Aug 17 '12 at 7:11
    
@JMax that's a valid point - I'll add that. thanks! –  Sathya Aug 17 '12 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.