Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I am used to using the KML button in Google maps to export my saved maps, as instructed in Export My Map as KML - which I got to from Google's own Maps data liberation page.

Having not done this since 5th July, as of today I can no longer see the KML button:

enter image description here

I've tried clicking in the link button, but it just pops up a dialog that supplies a URL, and gives me text to paste into website.

Am I missing something obvious? Or has Google just removed the ability to liberate one's Maps data now?

Or is there an unadvertised way to extract the data?

  • Web browser: Firefox 14.0.1
  • OS: Windows 7 Pro
share|improve this question
    
I just tried accessing My Places, clicked the "Edit" button and got the same screen, but once I clicked "Done", the KML link is there and working. Perhaps something in your browser is blocking it. Have you tried another browser? –  Traveling Tech Guy Aug 21 '12 at 15:25
    
@TravelingTechGuy D'oh. Thanks! You're right - do you want to add it as an answer, and I'll accept it - in case it helps others in the same situation. –  Clare Macrae Aug 21 '12 at 16:10
    
Answer added. Cheers! –  Traveling Tech Guy Aug 21 '12 at 16:40
add comment

5 Answers

up vote 3 down vote accepted

I just tried accessing My Places, clicked the "Edit" button and got the same screen, but once I clicked "Done", the KML link is there and working. Perhaps something in your browser is blocking it. Have you tried another browser?

share|improve this answer
    
Erm, yes - clicking "Done" solved the problem. Blush! –  Clare Macrae Aug 21 '12 at 20:22
add comment

I encountered the same issue. I found out the following:

Even though the KML image and link were not present in Chrome, I saw them in Firefox.

In Chrome, I looked at the source to see if these elements were simply hidden, but I didn't find them at all.

Then I disabled all of my Chrome extensions, reloaded the map, and the KML options were finally present, as in this screen shot:

enter image description here

I tried to isolate which of the extensions was responsible -- but I was not able to figure that out: Even after re-enabling all of my extensions, and reloading the Google Maps page, the KML options continued to be present.

share|improve this answer
    
Thanks. I think you can probably post screenshots now, with rep of 11. –  Clare Macrae Jan 6 '13 at 21:16
    
Indeed I can now -- and I have. Thank you! –  Joe DeRose Jan 15 '13 at 0:46
add comment

I know that this question already has an answer, but I just came across this problem myself, and Joe answered it for me. The only thing that is actually needed is a refresh of the page though. The steps to reproduce the problem are:

  1. Create a new map
  2. Save it and click done

The KML link will be missing. All that is necessary to see it is a page refresh. Note also that any changes that you make to your saved map will require a refresh for the KML to be up-to-date. The KML link will be as old as your most recent refresh.

share|improve this answer
1  
perhaps you could suggest this as an edit –  Alex Mar 21 '13 at 15:01
    
You should earn a +1, but I agree with @axrwkr. –  Jacob Jan Tuinstra Mar 21 '13 at 15:32
    
Sorry - I'm new. How do I suggest it as an edit? Thanks! –  Jonathan Apr 9 '13 at 23:20
add comment

Note that a manual option for exporting to KML is now available in the new Create Map interface for the new Google Maps (Map Engine Light). Find it under the little folder icon.

share|improve this answer
    
this solved it for me with the new interface. –  pluke Nov 4 '13 at 15:39
add comment

"the little folder icon"

As of March 2014

1)Make Map

2)Name Map Layer

3) Click "the little folder icon"

4) Select Export to XML from drop down menu

5) Choose layer from step 2

6) Press download and enjoy

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.