Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I am trying to add my weblink which has a white space, that is, %20 in it. When I add a website URL in a LinkedIn profile using the edit option, it shows no error. But when I click the link in my profile, it shows "Link Error".

I noticed the "%20" in the URL is replaced by "+".

How do I fix this problem?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

You would need to encode the encoded space - effectively, it looks like the LinkedIn.com website is unencoding the %20 to an actual space, which it then runs through a verification check which fails, as spaces in URLs are not supported.

So if you want to have a site with a URL like:

http://www.example.com/?id=this%20rocks

You'd need to enter:

http://www.example.com/?id=this%2520rocks

Where you have encoded the ampersand of %20 into the encoding for ampersand, which is %25. Essentially you are double-encoding the URL.

share|improve this answer
    
+1 for finding the root cause and a workaround to fix the problem, but this is probably better fixed by contacting LinkedIn and having them fix their site... –  Kevin Vermeer Aug 23 '12 at 21:15
1  
Even better would be to have a URL without spaces. Valid or no, some web servers and web browsers don't play nice with them. –  Al E. Aug 24 '12 at 2:00
    
Thanks Paul Mennega... your solution worked.. –  ashok Aug 25 '12 at 17:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.