Sign up ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

These three buttons in the bottom right corner of the YouTube player: the leftmost shifts the player to the left and makes it smaller (default), the middle one shifts the player to the center and makes it bigger, the rightmost goes fullscreen.

Starting from yesterday, 2012-09-06, it would appear the YouTube player won't go to the middle size when viewed with IE (at least, IE8). What happens is that the player shifts to the center, but doesn't grow, remains as small as in the "left" mode.

I have tried different computers, including the office ones, same behavior.

When viewed with Firefox, it grows just fine.

Is there a trick or a setting to make it work as usual in IE?

share|improve this question
First of all, you should not expect things to work fine when using IE as IE still not supports all standards. However, I've had the same issue in Chrome (Mac) for a while. Since a few weeks it began working again. I have no clue what made it work again, though. – Steven Roose Sep 7 '12 at 12:26
I'm not seeing the issue in Chrome mac and I cleared my flash and browser cache after reading this question to see if the changes hadn't filtered down yet. – Dez Sep 7 '12 at 18:26

2 Answers 2

Solution 1

You may want to try clearing your cache by doing the following

  1. Once your browser is open, click the Tools menu. Or, optionally you may simply press Ctrl+Shift+Delete to open the Delete Browsing History window (and skip step 2)
  2. Click on Delete Browsing History...
  3. Select Temporary Internet Files.
  4. Click the Delete button near the bottom of the window to delete your temporary files (i.e. clear your cache).
  5. If you want the browser to automatically clear the cache whenever you close it, click the Advanced tab. Click to check the box next to the Empty Temporary Internet Files folder when browser is closed option (in the section labeled Security). Click OK. This will delete everything except cookies. Note: IE8 has a "feature" which retains some cookies even after you clear your cache if you do not UNCHECK the "Preserve Favorites Website Data." If you truly need to clear your cache, you will want to uncheck this!

(ref: How to Clear Browser Cache)

If this does not work give another browser a try and see if that works.

Solution 2

You can try to do some of the fixes listed on Microsoft Supports page relating to Video Issues.

Solution 3

According to the YouTube HTML5 page Internet Explorer has the following capability: Microsoft Internet Explorer 6, 7, or 8 with Google Chrome Frame installed (Get Google Chrome Frame). One of the issues notes states: Fullscreen support is partially implemented. Pressing the fullscreen button will expand the player to fill your browser. If your browser supports a fullscreen option, you can then use that to truly fill the screen. Upon visiting the HTML5 page check at the button of the page and see if it says you're using html5. If you are using html5 on youtube, turn it off and see if this fixes the issue!

share|improve this answer
Well, I tried various computers, including ones from which youtube has never been visited before. It would appear the issue exclusively applies to IE8, other browsers including IE9 work fine. Youtube has announced ceasing support for IE7, but not IE8. – GSerg Sep 8 '12 at 7:37
@GSerg I have added two more solutions. I'd try Solution 3 before 2. – Fogest Sep 8 '12 at 12:19
I'm not using Google Chrome Frame, not using html 5 as IE8 does not support it, do not have any problems with going to fullscreen. The tips from Microsoft relate to video playback in general, which works okay. – GSerg Sep 9 '12 at 11:28

When going into Theater Mode on YouTube, the video player will enlarge only if your viewport is tall enough. The viewport is the area in your browser where the webpage is displayed, so it does not include your address bar, title bar, etc.

I had the same problem as you—Theater Mode would simply move the video to the center but would not enlarge it. I eventually realized that I had too many toolbars, so my browser's viewport was too small. I moved my bookmarks bar to next to the address bar, so that the viewport got taller by 50 pixels or so, and that was enough to allow YouTube to enlarge the video in Theater Mode. So, try removing toolbars, etc. and anything else that shrinks your browser's viewport, vertically, until Theater Mode kicks in with an enlarged video.

You can test how YouTube enlarges videos by simply viewing the video player in Default mode (the non-Theater Mode one), then shrinking the browser's viewport, and seeing how the video player adjusts its size to compensate.

Another fix for the same problem is to zoom out, or shrink the text, so that the viewport is effectively smaller.

share|improve this answer
Thank you for the answer. I don't have any toolbars at all, and the zoom is 100%. In fact the problem just went away a couple of weeks after I asked the question, I didn't do anything to make it happen and I don't know why it went, so I even forgot about this question completely! – GSerg May 15 at 8:04
Okay glad to hear it. Perhaps you upgraded IE and the new version had a taller viewport because some status bars, toolbars, etc. were removed? That's what happened in Firefox, my primary browser, a year or two ago. I don't use IE so I don't know about that. But considering how popular this question is, I hope that my answer can help others. It took me an hour or two to figure out the problem, and a minute or two to actually fix it. – Gary May 15 at 16:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.