Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I have a gmail address that's my primary email. I have a couple short email addresses on my own domain that I have set to forward to the gmail acct.

For various reasons, I like to email these addresses from my gmail account (which then forward back to myself). The frustration is, these emails do not show up in my inbox - only the ALL MAIL tab.

There's a filter for skip the inbox. Why can't there be one for put it in the inbox?

share|improve this question

migrated from superuser.com Oct 3 '12 at 23:03

This question came from our site for computer enthusiasts and power users.

    
I'm confused. If your forwarding emails from your other email addresses (not gmail), then what's the problem? Forwarded emails should always get thrown to your gmail account. –  Ace Legend Oct 3 '12 at 15:29
    
Not sure what you mean "get thrown to.." but the emails DO get forwarded to the account, but for some reason skip the inbox –  Zach L Oct 3 '12 at 17:48
    
Oh. I see. How are you forwarding them to your inbox. Are you doing it through gmail or are you having the other accounts forward to your gmail account? –  Ace Legend Oct 3 '12 at 17:52
    
I have a couple short email addresses on my own domain that I have set to forward to the gmail acct. –  Zach L Oct 3 '12 at 17:52
    
That's odd. Now I see why you asked this question. Usually forwarded emails get sent straight to the inbox. Odd. –  Ace Legend Oct 3 '12 at 19:50
show 5 more comments

1 Answer 1

up vote 3 down vote accepted

As one option, you could make sure that your email filter turns on "Never send it to Spam" and "Always mark it as Important".

No Spam, Mark Important

In your Inbox setting, you can "Override filters" and always include Important emails in the inbox.

Override Filter, Include Important

I don't have a way to test this suggestion, but could you give me feedback as to whether this worked for you?

share|improve this answer
1  
I probably should have experimented with that stuff some more before posting. It seems to have worked. I think it was the mark as important option that fixed it for me! Thanks! –  Zach L Oct 3 '12 at 17:50
    
I have since noticed a somewhat annoying consequence of this. Now ALL of my sent mail appears at the top of my inbox :-/ –  Zach L Oct 8 '12 at 16:04
    
Your filter needs to include only the from addresses where you would like to see this behavior. The place where you designate from is the screen just prior to designating Always mark as important –  dmcgill50 Oct 9 '12 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.