Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

This has been going on for some time. Whenever I type twitter.com into Chrome's omnibar, I am redirected to https://twitter.com/search/%7BsearchTerms%7D?source=desktop-search. Given the tweets showing there, this seems to be a common problem, though my searches only turned up one guy who recorded a video describing the problem.

After clicking Twitter's Home button, I wind up at the home page I expected to reach in the first place.

I have been able to reproduce this on Chrome on Windows, Mac OS X and Linux. It doesn't seem to affect other browsers such as Firefox. I have cleared cache, cookies, tried a completely different machine, the usual stuff.

My current environment is: Chrome Version 22.0.1229.94 m on Windows 8. I have also experienced this on many previous versions of Chrome, running on Fedora 17 and OS X 10.7.

share|improve this question
add comment

1 Answer

up vote 7 down vote accepted

Search redirects in Chrome more often than not mean that there's a custom Search URL defined under Search settings.

You can check this from Chrome Menu → Settings → Manage Search Engines (or by pasting chrome://settings/searchEngines in the omnibar. If there's one defined for twitter, delete that entry and it should work fine after that.

share|improve this answer
    
I removed the entry for Twitter and the problem is gone. I never really wanted to search Twitter from the address bar. –  gtirloni Nov 22 '12 at 13:48
    
I wonder how a small set of us created this search rule by mistake. I lived with this issue for ~7 days before searching for this fix. :P –  rdrey Dec 12 '13 at 4:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.