Web Applications Stack Exchange is a question and answer site for power users of web applications. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, this is messed up. I opened up my budgets spreadsheet as I do every week, and realized that I could only edit 1-2 cells before everything would freeze up. Inspecting the UI, I found a tiny lightning bolt in a circle next to the title whose hover text reads "You are offline". No Google, I'm not. This is in Chrome, which appears to have updated itself today.

I uninstalled the Google Drive desktop program (had been meaning to anyway after reading this scary article) and also removed Google Drive from the list of apps on my new tab screen. No luck.

Other details:

  • It seems to apply to other spreadsheets too, but not text documents.
  • It seems to work fine in Firefox
  • Chrome is version 22.0.1229.94
share|improve this question
I don't have a solution, but I've seen the same thing. Obviously the "heartbeat" being sent back to the Google servers isn't returning (on time) and so the client drops into offline mode. I've not been able to find a consistent time, place, or circumstance for when this happens. – Al E. Oct 24 '12 at 12:53
I just experienced this not too long ago with the Drive client itself. Here, I opened the Dev console and can see that a DNS lookup is failing. I think there's a bug related to the "0." hostname. I've seen this before and the following fixed it then and now: From: superuser.com/questions/203674/how-to-clear-flush-the-dns-cache-in-google-chrome "Navigate to chrome://net-internals/#dns and press the "Clear host cache" button." – rainabba Jul 23 '14 at 21:12
up vote 2 down vote accepted

It seeeeems that this is no longer an issue thanks to some update to something. Fingers crossed.

share|improve this answer

I found it beneficial to investigate whether or not the computer's security software is a factor. For me, Kaspersky automatically updated in such a way that inhibited my ability to edit in Google docs. It was the result of an 'encrypted connection scanning' issue.

This site was helpful: http://www.htgsd.com/information-technology/google/google-drive-trying-to-connect-to-edit-offline-turn-on-offline-sync-when-you-reconnect/

I'm wondering if others might experience a similar problem even with different software. I hope everyone finds their remedy.

share|improve this answer
Thank you! I saw that requests to 0.docs.google.com were failing with no reason in Chrome. I tried whitelisting it in adblock, but it wasn't until I disabled Encrypted Connection Scanning in Kaspersky that it came right. – Wogan Nov 28 '15 at 21:01

This is probably Google Docs/Drive's issue. I have the same issue and have tried turning off the offline editing but no luck. Since the offline mode is only supported by Chrome for now according to Google support doc, the easiest walk around is to use IE/Firefox/Safari.

share|improve this answer

It just happened to me, and turned out to be script blocking.
If you are using ScriptSafe or any of the other script blocker - make sure scripts originating from 0.docs.google.com (and possibly others, as the implementation changes with time) are marked "allowed".
Needless to say - make sure the scripts you allow are safe before you allow them...

share|improve this answer
Interesting. I don't use any kind of script blocking, so it must have been something else causing it for me... – MalcolmOcean Mar 14 '13 at 4:34

I had this problem with Firefox.

I did this: Tools → options → security

I had Warn me when sites try to install add ons checked.

I added an exception for 0.docs.google.com and now it seems to be working ok (for now).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.