Take the 2-minute tour ×
Web Applications Stack Exchange is a question and answer site for power users of web applications. It's 100% free, no registration required.

I am using Gmail. I want incoming mail that matches a label to skip the inbox. This does not seem to work. The instructions from Gmail include the following:

To keep organized, many people like to have incoming messages automatically labeled and removed from their inbox until they can look at them later at a more convenient time. If you want to do this, make sure to select Skip the Inbox (Archive it) and Apply the label: when you create your filter.

The filter looks like this:

Matches: from:(jean123@yahoo.com) Do this: Skip Inbox, Apply label "Jean123", Never send it to Spam

However, such mail continues to appear in the inbox as well as All Mail. What am I doing wrong? (It also appears in a label for "Jean123" and I'm not sure how it got there but that is beside the point.)

share|improve this question

migrated from superuser.com Oct 26 '12 at 14:32

This question came from our site for computer enthusiasts and power users.

add comment

2 Answers 2

up vote 8 down vote accepted

This can be fixed by using the Inbox settings page and uncheck the option to have important mail ignore filters.

share|improve this answer
4  
Also, ALL Mail goes to the "All Mail" box regardless of filters as the name implies.. –  TheX Oct 26 '12 at 14:14
add comment

The Inbox setting Filtered mail:Override filters - Include important messages in the inbox that may have been filtered out. will keep the hidden label "Inbox".

All messages have the "All Mail" label. The Override tells gmail not to strip the "Inbox" label if it believes the message is important. Your filer added the "Jean123" label, and kept it out of spam.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.